I'm trying to achieve my remote service with port 5601. But unfortunately i can't open the website.

Here is something i tried to find out why it's not working:
I logged in remote server and tried "telnet localhost 5601" and "telnet 192.168.x.x 5601", it works fine.
But "telnet 114.116.x.x 5601" failed.

The remote server i use is a cloud server and i can reach it using ssh. And i also checked some of my docker service with port (10450, 10460...), the result is they can be reached using external ip. SO maybe the problem is on 5601 service. And then i write a little helloworld web program with listening host "" to find out. turns out it cannot be reached from external ip neither.

So is there something wrong with my service or my network? If there is, how can i fix it? Really appreciated.

os: centos7
firewall: off
network: ok

tcp        0      0  *               LISTEN      6438/python    
tcp        0      0  *               LISTEN      6121/./bin/../node/   
tcp        0      0    *               LISTEN      1403/sshd           
tcp6       0      0 :::443                  :::*                    LISTEN      18807/docker-pro    
tcp6       0      0 :::10460                :::*                    LISTEN      3966/docker-proxy-c    
tcp6       0      0 :::10430                :::*                    LISTEN      4552/docker-proxy-c

telnet 114.116.X.X 10450 
Trying 114.116.X.X...    
Connected to 114.116.X.X.
Escape character is '^]'.   

telnet 114.116.X.X 5601 
Trying 114.116.X.X...

just won't work for 5601 and 2700.

  • 1
    Is the IP address attached to a router, or directly to this machine? (i.e. does it show up in ip addr of this machine or not?) – user1686 Apr 16 '19 at 8:45
  • @grawity Hi, the IP address (114.116.x.x) does not show up in ip addr, the remote machine is a cloud server like AWS. so i think it's attached to a router? – J.ben Apr 16 '19 at 9:37
  • @grawity Hi again, since you mentioned router, i went to the manager and talked about this. He told me yes that he restricts all the ports exposed from the cloud server regardless of my firewalls off. After he opened those ports for me, i think this problem will be sovled. So thank you for your advice and the editing and the encouraging reputation, it helps a lot. Would you like to fill the answer so i can accept it? – J.ben Apr 16 '19 at 11:16

the IP address (114.116.x.x) does not show up in ip addr,

Then it's not actually the machine's IP address – it belongs to some sort of NAT gateway. This means that telnet 114.116.x.x is not a simple loopback connection, but actually goes out to the network and is returned back by a router, which can have its own firewall and enforce packet filtering. (As you've eventually found out.)

(This might also indicate that the server is behind 1:many NAT (as in home LANs), in which case the blocking doesn't need to be deliberate, as the router doesn't even know which server is supposed to receive packets unless "port forwarding" rules are manually created.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.