12

I use dolphin as my default file browser. The recent releases have moved the options to configure single/double click open of files.

Settings -> Configure Dolphin -> Navigation - Mouse

I find that I use double click to open as a single click to select allows me to manage my files a lot more easily.

How do I change these settings in the new version of dolphin?

I am using i3 windows manager on manjaro distro.

3 Answers 3

15

Start System Settings then type in the search box "double click" and select Workspace Behavior

enter image description here

Then under General Behavior change the radio button from Opens them to Selects them

enter image description here

3
  • 1
    This is the current correct method. Everything else is either outdated or a workaround that doesn't fix the issue.
    – anahata
    Aug 22, 2023 at 16:28
  • Sadly, this is currently not working with dolphin 23.08.4 given by snap instead of apt (kubuntu 22.04.03) Jan 8 at 10:13
  • With Plasma 6 changing the default, this question and answer got a lot more relevance.
    – JepZ
    Mar 6 at 21:48
10

After weeks of trying different things.

Using systemseting5

Option 1

I could not follow these instructions. As they relate to an older version of dolphin and KDE.

systemsettings from the command prompt -> Input Devices under the Hardware section -> Mouse section in the left-hand side menu > Double-click to open files and folders

Option 2

I could not follow these instructions As my systemsettings5 did not have all the options available to set

Under Workspace section > Desktop Behaviour > Workspace > Click behaviour > Single/Double Click Option

I didn't have Desktop Behaviour as an option. I fixed this by installing the missing package

sudo pacman -S plasma-meta

Then I could follow the above options.

Alternatives command line

Change the options in the kdeglobals config of my user.

vim ~/.config/kdeglobals
...
[KDE]
...
SingleClick=false
...

Restart.

2
  • +1 for the config file location and field
    – mx1up
    Jul 27, 2019 at 9:40
  • [KDE] ... SingleClick=false 👍 Thanks, this worked for me. Sep 5, 2023 at 12:25
0

You can work around this problem with your keyboard using

Ctrl+left click

That will let you single click files to do file operations like move and copy etc.

1
  • My config is Manjaro / Arch is broken and I can't switch modes single / double click through the settings. :<.
    – nelaaro
    Aug 9, 2019 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .