I have been having this problem for a long time now. NetBeans is almost impossible to use with C/C++, maybe because it was not made for it in first place.

Anyways what happens is this: I have this setup for C/C++

alt text

But, the programs are displayed like this:

alt text

It is not able to find any header file!! I know it is a C++ program, the same thing happens with #include <cstdio>. As a result, it is not able to find the definition of printf and fails.

Same thing happens with a .c file.

Also, gcc works fine from the command line.

the problem exists still:

$ find / -name stdlib.h

alt text

Did someone face this problem before? What do I need to do to make this work?


You should go on the tab "Code Assistance" and check the include paths. Happened to me that the paths referenced something like


but i upgraded to gcc 4.4, so i had to change that to


hope that helps


Seems from your screenshots that Netbeans doesn't look in all your include paths. Please make sure that all your include paths are contemplated under "Code Assistance"

  • I tried that. not working still. I've added screenshots in the question. Please have a look. thanks! – Lazer May 19 '10 at 14:20
  • 1
    @eSKay: you said that gcc compiles fine from the command line. Does it compile directly from netbeans too? Try compiling with full debug info and choose "reparse project" from CodeAssistance menu. Some times this helps. – Mr Shunz May 20 '10 at 8:59

I had the same problem with NB 6.9 and solved by updating all my C++ plugin's (Tools > Plugin).


Mine works. These are my settings:

In Options -> C/C++ -> Code Assistance Tab -> C compiler tab ->

I have the following in the "include directories"


The last one /usr/include is the one that should have stdio.h and stdlib.h.

I was able to get the C++ code assistance to work by adding /usr/include/c++/4.4.3 in the c++ code assistance tab.

Edit: Your find command seems to have found all the relevant directories. Looks like you might just have to add them to the code assistance tab.

  • How to include directories and it's subdirectories at once? – Vivek Kumar Dec 28 '14 at 10:27

I had the same problem in Netbeans IDE 7.3 and Ubuntu 12.04 LTS, and I solved by removing this line


in Options -> C/C++ -> Code Assistance Tab -> C compiler tab

and Options -> C/C++ -> Code Assistance Tab -> C++ compiler tab

in this directory I dont have any header file.

I hope can help.

  • Its important to note that there are 2 tabs (as Walter specified). Be sure the "C++ complier" tab has the include directories. Try to build your project. Most of the warnings/errors may be cleared after that. – lepe May 27 '15 at 7:37

I've the same problem with NetBeans 7.2.1. In fact when I created a C/C++ project, the main file was in .C extension (main.c).

I just select extension cpp instead and it works.


I added /usr/include/c++/4.8/ to the include directories and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.