49

I am using manjaro / arch linux and I see the following error messages in my system log.

journalctl -f 
...
dbus-daemon[798]: [system] Activating via systemd: service name='org.freedesktop.resolve1' unit='dbus-org.freedesktop.resolve1.service' requested by ':1.4' (uid=0 pid=799 comm="/usr/bin/>
dbus-daemon[798]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.resolve1.service': Unit dbus-org.freedesktop.resolve1.service not found.
...

How do I fix this problem

1
  • 1
    It's apparently also possible to run into this problem when trying to run resolvectl flush-caches with "Failed to get global data: Unit dbus-org.freedesktop.resolve1.service not found." printed to the console. (systemd-resolved was inexplicably not running, which would explain previous troubles resolving domains.) Commented May 29, 2020 at 1:20

1 Answer 1

74

This problem is related to the network-manager and systemd-resolved.service.

After reading the the manjaro forums and the arch wiki

You have 2 options

configure network-manager to not use systemd-resolved.service

vim /etc/NetworkManager/conf.d/no-systemd-resolved.conf

With this content:

[main]
systemd-resolved=false

Activate and use systemd-resolved.service

check if it is running and enabled

systemctl status systemd-resolved.service
● systemd-resolved.service - Network Name Resolution
  Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; disabled; vendor preset: enabled)
  Active: inactive (dead)
    Docs: man:systemd-resolved.service(8)
          https://www.freedesktop.org/wiki/Software/systemd/resolved
          https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
          https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients

Enable and start it.

systemctl enable systemd-resolved.service
Created symlink /etc/systemd/system/dbus-org.freedesktop.resolve1.service → /usr/lib/systemd/system/systemd-resolved.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-resolved.service → /usr/lib/systemd/system/systemd-resolved.service.
systemctl start systemd-resolved.service
systemctl status systemd-resolved.service
● systemd-resolved.service - Network Name Resolution
  Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
  Active: active (running) since Fri 2019-04-19 10:36:53 SAST; 32min ago
    Docs: man:systemd-resolved.service(8)
          https://www.freedesktop.org/wiki/Software/systemd/resolved
          https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
          https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
Main PID: 21150 (systemd-resolve)
  Status: "Processing requests..."
    Tasks: 1 (limit: 4915)
  Memory: 5.0M
  CGroup: /system.slice/systemd-resolved.service
          └─21150 /usr/lib/systemd/systemd-resolved

That solved the errors from coming up in the logs.

4
  • 1
    Next NetworkManager version will avoid trying to contact resolved if it is not already running. Commented Apr 19, 2019 at 11:25
  • 11
    I had this and started&enabled systemd-resolved. But why it fails at the first place? Arch Linux doesn't come with default support for domain name resolution?
    – Artyom
    Commented Oct 7, 2019 at 7:45
  • 1
    @Artyom If it can be of any consolation, the only service I've consistently had problems with is NetworkManager. The only one whose name starts with a capital letter, to my knowledge... I try to use netplan without NetworkManager as much as possible.
    – Déjà vu
    Commented Sep 1, 2023 at 12:43
  • Thanks for the life saving help. Howver oddly, while I can now ping sites, nslookup doesn't work, I guess because it uses /etc/resolv.conf Commented Sep 18, 2023 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .