When I back to home, I open the Virtual Box and it shows up:

Failed to get VirtualBox COM Obj.
Cannot register the hard disk 'PathA' {75df0d7e-4c8f-4dcb-b89b-110ad8c061a1} because a hard disk 'PathA' with UUID {7df6ea8d-5425-43d2-bbc1-ee38c2e8c3f5} already exists.
return code: E_INVALIDARG (0x80070057)

Then... I go to the Google and look up this problem...
After that.. I run the command:

VBOXMANAGE.EXE internalcommands sethduuid "PathA"

VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Cannot register the hard disk 'PathA' {75df0d7e-4c8f-4dcb-b89b-110ad8c061a1} because a hard disk 'PathA {7df6ea8d-5425-43d2-bbc1-ee38c2e8c3f5} already exists
VBoxManage.exe: error: Details: code E_INVALIDARG (0x80070057), component VirtualBoxWrap, interface IVirtualBox

Thanks for your help!


2 Answers 2


So.. Guys.. I found the solution...

First, going to your user dir such as: C:\Users\Administrator Then, find the dir that called: .VirtualBox Finally, delete that dir.

Reboot the Vbox and you finally can use it!

  • Were you able to figure out WHY this error occurs and therefore WHY this solution fixes it? It seems to me that just deleting things without understanding what is being deleted and why it is necessary is a recipe for unforeseen and negative consequences. Commented Apr 22, 2019 at 18:52

The solution that worked for me is as follows:

  1. Make sure VirtualBox Manager is not running.
  2. Open the files ~\.VirtualBox\VirtualBox.xml and ~\.VirtualBox\VirtualBox.xml-prev.
  3. Edit the <HardDisks>...</HardDisks> section in these files to remove the duplicate entry of <HardDisk />.
  4. Now run VirtualBox Manger.


    <HardDisk uuid="{38f266bd-0959-4caf-a0de-27ac9d52e3663}" location="~/VirtualBox VMs/VM1/box-disk001.vmdk" format="VMDK" type="Normal"/>
    <HardDisk uuid="{a6708d79-7393-4d96-89da-2539f75c5465e}" location="~/VirtualBox VMs/VM2/box-disk001.vmdk" format="VMDK" type="Normal"/>
    <HardDisk uuid="{bdce5d4e-9a1c-4f57-acfd-e2acfc8920552}" location="~/VirtualBox VMs/VM2/box-disk001.vmdk" format="VMDK" type="Normal"/>

Note in the above fragment that the last two entries refer to the same VM but have different uuid's. One of them is invalid and should be removed. Which one is invalid can be found put by hit and trial -- first remove the second entry and try; if it doesn't work, remove the third entry.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .