0

I downloaded virtualbox-6.0_6.0.6-130049_Ubuntu_bionic_amd64.deb. When I tired sudo dpkg -i virtualbox-6.0_6.0.6-130049_Ubuntu_bionic_amd64.deb it fails by the following errors:

dpkg: error processing package virtualbox-6.0 (--install): dependency problems - leaving unconfigured Processing triggers for systemd (229-4ubuntu21) ... Processing triggers for ureadahead (0.100.0-19) ... Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ... Processing triggers for desktop-file-utils (0.22+linuxmint1) ... Processing triggers for mime-support (3.59ubuntu1) ... Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ... Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ... Errors were encountered while processing:

Updated Question I tried this cat /etc/upstream-release/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=16.04 DISTRIB_CODENAME=xenial DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS" So I downloaded virtualbox-6.0_6.0.6-130049_Ubuntu_xenial_amd64.deb. Then tried sudo dpkg -i virtualbox-6.0_6.0.6-130049_Ubuntu_xenial_amd64.deb I got error:- (Reading database ... 226145 files and directories currently installed.) Preparing to unpack virtualbox-6.0_6.0.6-130049_Ubuntu_xenial_amd64.deb ... Unpacking virtualbox-6.0 (6.0.6-130049~Ubuntu~xenial) over (6.0.6-130049~Ubuntu~xenial) ... dpkg: dependency problems prevent configuration of virtualbox-6.0: virtualbox-6.0 depends on libcurl3 (>= 7.16.2); however: Package libcurl3 is not installed.

dpkg: error processing package virtualbox-6.0 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for systemd (229-4ubuntu21) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 virtualbox-6.0

How do I install it?

  • You should download the Virtualbox version for the Ubuntu version your Mint is based on. – GabrielaGarcia Apr 22 at 14:45
  • @GabrielaGarcia Pls check updated question – masiboo Apr 23 at 16:17
1

You should install the dependencies that the error quotes (libcurl3 and possibly others). Because of the fact that you are not installing virtualbox via apt (the primary package manager) those are not installed automatically and you have to do it manually. You can do it by typing:

sudo apt install libcurl3 [eventual-other-packages]

And retrying with dpkg -i virtualbox-6.0_6.0.6-130049_Ubuntu_xenial_amd64.deb.

You can also try to make them installed automatically by typing

sudo apt --fix-broken install

after getting your error (with dpkg -i virtualbox-6.0_6.0.6-130049_Ubuntu_xenial_amd64.deb).

In the first version of your question there was also a compatibility problem (virtualbox for Ubuntu 18 instead of 16) but i see you already solved that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.