2

I changed the file chooser a while back because my version of Libreoffice Writer crashed all the time when I would go to choose a file.

There have been a few versions between then and I would like to try it out without having to purge libreoffice.

Where can I set the file chooser from the image below to the nice KDE style one I had before? I forgot where the setting was.

Old Style File Chooser

1 Answer 1

4

The setting was removed from the options menu -- see the LO 6.0 release notes. You can still find it in the expert configuration menu. Go to LibreOffice > General > Advanced > Open Expert Configuration. Search for "UseSystemFileDialog" and double click to toggle.

Before I found this, I had written up some other suggestions, which I'll leave below.


You haven't stated what VCL plugin is being used. See Help > About LibreOffice. If it's not using the KDE plugin, I expect that this would affect the file dialogs as well.

Check that you have the relevant package installed. On Ubuntu 18.10, this is libreoffice-kde5 (or on older versions, libreoffice-kde).

Usually the appropriate integration package will be used if installed. If not, check that you haven't set the environment variable OOO_FORCE_DESKTOP (or anything else related to LO) in any dotfiles, as well as the .desktop files for the applications menu. As a final resort, you could set the variable OOO_FORCE_DESKTOP to "kde" (or perhaps "kde5", I'm not sure).

1
  • I found that my Ubuntu 20.04 system 'randomly' flipped over to showing me the Qt file dialog in LibreOffice 7.1.6.2, when what I want/prefer is the Gtk dialog, in common with other programs on my system. Don't know why this happened... but this Expert Configuration option to set UseSystemFileDialog to true successfully put it back to what I'm used to. Thanks!
    – jdpipe
    Oct 28, 2021 at 23:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .