Recently, I've tried to access a specific website (other websites work) but I get a blank page on my computer. I'm sure the problem is my computer because I tried on the same network with my smartphone (w/ google chrome) and it works. Also tried to change the browser on my computer (safari, google chrome, firefox), restarting the computer, and also restarting the wifi router. I also tried to clear cache on the google chrome browser and switching off the adblocker.

I have no idea why it still does not work, any suggestions ?


  • Is this an HTTPS address? If you open DevTools (F12 in Chrome), switch to the Network tab, and hit F5 to reload the page, does it literally say "content-length: 0" in the response? In the Security tab, does the HTTPS certificate look as expected, or is it issued by Some Antivirus Software CA?
    – user1686
    Apr 22, 2019 at 8:18
  • It is a https adress, no "content-length: 0" in the response, and looks normal in security tab. Using the non-https address doesn't resolve the problem.
    – thchem
    Apr 22, 2019 at 8:29


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.