0

I'm running RedHat in Virtualbox 6.

This is just a terminal base OS so there is no mouse.

I can previously hit the RCTRL and use the mouse again in the host. Happy and everything was good.

Until...

I changed my keyboard from jp to us (japanese to english):

$ localectl set-keymap us

Then I can no longer hit the RCTRL to show my mouse back and use the host OS. Since I am using Windows, I am able to use CTRL+ALT+DEL and finally the mouse showed up again and I'm able to navigate.

I change my setting in virtualbox so I can show up the mouse anytime File -> Preferences -> Input -> Host Key Combination and changed that value from RCTRL to HOST. Actual values are from 'Right Ctrl' to 'Left Windows' using my new key HOST (instead of RCTRL).

Everything is working fine now. All keyboard is mapped correctly and I can use the applications.

But...

My question:

Why won't Redhat detect RCTRL? or better yet, how can we make redhat detect RCTRL?

P.S. RCTRL+a jumps the cursor to start of line and RCTRL+e jumps the cursor to end of line.

More information:

$ localectl status
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc105+inet
X11 Options: terminate:ctrl_alt_bksp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.