1

Update: issue appears fixed, raises more questions than it answers

Goodness gracious, so I just tried to simply enable the policy and then disabling it again (the good old turning it off and on again), and of course it's fixed now... Still doesn't make sense though because of the complete reset of all policies to factory defaults before, that didn't help (I rebooted several times in the mean time as well). Windows has mysterious ways I guess.

Although this doesn't comfort me at all. Why did Windows Update see the wrong/phantom policy setting before? Are (group) policy settings even reliable? Is Windows reliable for that matter...


Windows Update is claiming that the policy to exclude driver updates has been set, which the screen shot below proves is not the case:

Windows Policies

What could be the cause of this?


Windows specifications & Environment

Edition:    Windows 10 Pro  
Version:    1809  
OS build:   17763.437  

The computer is running in a home environment (standalone).

What I've tried so far

  • Reset all group policies to factory defaults:
RD /S /Q "%windir%\System32\GroupPolicyUsers"
RD /S /Q "%windir%\System32\GroupPolicy"
gpupdate /force
  • Checked the state of the ExcludeWUDrivers registry entry (located at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UpdatePolicy\PolicyState): 0
1

you should check this entry too : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings\ExcludeWUDriversInQualityUpdate

1
  • Welcome to Super User! Generally, answers are much more helpful if they include an explanation of what the code is intended to do, and why that solves the problem without introducing others. – MMM Dec 2 '19 at 12:59
0

I had the same issue. I was able to get the problem to go away by enabling the "Do not include drivers with Windows Update" policy, and then setting it back to "Not Configured".

3
  • The author’s screenshot clearly indicates this policy is already set to that value. – Ramhound Dec 2 '19 at 12:08
  • @Ramhound it is necessary to toggle it explicitly, then all will work ok – vladon Dec 10 '19 at 14:33
  • @vladon - If one has to toggle this policy then there is something else going on. I suspect the author of this answer simply didn't understand the author of the question had already configured the policy. – Ramhound Dec 10 '19 at 15:05
0

Probably something in the registry still. These are all the places to look, thanks to Ten Forums:

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\current\device\Update] "ExcludeWUDriversInQualityUpdate"=dword:00000000

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\default\Update] "ExcludeWUDriversInQualityUpdate"=dword:00000000

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\default\Update\ExcludeWUDriversInQualityUpdate] "value"=dword:00000000

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings] "ExcludeWUDriversInQualityUpdate"=dword:00000000

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate] "ExcludeWUDriversInQualityUpdate"=dword:00000000

0

Do this for all policies in the Administrative Templates\Windows Components\Windows Update group: First change to Enabled (or Disabled) then click Apply, then restore again to Not Configured and click Apply again. When you "fix" the correct policy, the annoying notice will disappear instantly if you focus "Settings\Update", so no need to restart and you can check after each change (saves you extra clicking).

enter image description here

Also do the same with Allow Telemetry in Administrative Templates\Windows Components\Data Collection and Preview Builds - make sure it is not Disabled.

enter image description here

-1

Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate and delete the ExcludeWUDriversInQualityUpdate entry.

Found here: Tenforums: Some settings are managed by your organization

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.