1

Back Story: Recently i have got a new phone (Android Pie), and i still have my old one (Android Oreo). I have been using an external SD card (64GB) for the past 3 years with my old phone, and now i want to use that SD with my new one.

Problem Statement: The problem is, i can't erase nor format the SD card for some reason. I have tried to format it from the old phone, it showed progress and said that format was successful, but when i went to the SD, everything was still there, as if a format didn't happen at all. I have also tried to format it from my mac (macOS 10.14.14) using disk Utility, SDHC "SD card formatter" the official application from their website (Quick format and Overwrite format), from terminal (as i usually do when something similar happens) using

diskutil eraseVolume free EMPTY /dev/$VOLUME$

and i have also tried to delete the files inside the SD card manually using

rm -rf /Volumes/$VOLUME$

But nothing seems to work, even after all of the things i have done above the original information stay no matter what.

Note: After each attempt to format the SD card has to unmount in order to complete the format process. I have noticed that when the SD card gets unmounted and then mounted again, only then the original information come back somehow, like some kind of magic. When i have done the manual format, i saw that the SD card was empty before unmounting, but after mounting it again, everything came back again. It's not a problem with reading and writing, i have the writing and reading permissions for the SD card, and i have checked that multiple times. I have posted this before on, Android enthusiasts, but it got on hold, because it was android independent.

EDIT1: As i have explained in the note, it's not a problem with reading and writing, i have these permissions, and able to read and write into the SD card with no problem what so ever. If i do so after i have formatted before unmounting, the information stays there, and gets overwritten by the old information when i unmount and remount. if i do so after formatting and unmounting, then mounting again, and the old information come back, i can add files to the old information that has returned. It doesn't make any sense...

EDIT2: So far it looks like the SD has reached it's end. I will try once more and see if anything new happens.

  • can you write to the card? – Robert Paulsen Apr 23 '19 at 13:17
  • 3
  • You may also wish to search in apple.stackexchange.com for a solution since this involves MacOS. – K7AAY Apr 23 '19 at 17:11
  • You say that after trying to format, when you remount the card, all of the old stuff is still there. Are you basing that on just a directory listing, or did you actually test opening a few of the files? You also report getting progress messages saying the format was successful. That's a strange twist. SD cards do have a limited life, and 3 years of use might have reached it. When it loses the ability to write to the card, it typically goes into read-only mode, which allows you to off-load your files to other media before it dies completely. And that may well be what's happening. (cont'd) – fixer1234 Apr 23 '19 at 19:19
  • However, you usually get messages that it's write-protected or read-only, or other error messages. Regardless of what's underlying the problem, there isn't a lot you can do when flash media starts acting flaky. In some cases, you can get it working again, but it won't be reliable media, and the next failure could leave you unable to extract your files. SD cards and other simple flash media (excluding SSDs), should be considered disposable, and at the first sign of problems, off-load your files and replace it (or at least don't rely on it for anything important). – fixer1234 Apr 23 '19 at 19:20
0

Appearing to format until re-mount is a known symptom - I just can't find an authoritative ref to cite right now; but it is a known fail symptom. I used to get through literally thousands of SD cards for work & this was one of the 'bin it' criteria. They're not worth fighting once they start to fail. - Tetsujin

So, at the end it was just the SD card failing, which means it's life has ended. And as @Tetsujin said 'bin it' criteria is what has to be done.

| improve this answer | |
0

Could you try this

https://up4pc.com/aomei-partition-assistant-crack/ i tryied the standard version and made wipe device it wiped my 64gb Sd card during about 20 minutes .after inserting that sd card again to my computer it disappeared from windows explorer .but in that software and in disk management tool its appear. now i downliaded the crack of that software but i did not get the chance to try it. its the best tool amoong several solutions i tryied . the last thing i will do is try the full vesrion using this crack. hope that help us. if it helped you then tell us all the best

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.