0

I'm trying to use a Bluetooth LE device with a computer. I can connect just fine and I'm receiving data as expected. If I lose connection then try to reconnect, however, I am no longer seeing data. The computer's Bluetooth Settings still say it's connected and the status LED on the device still indicates a connection, but I do not see any data.

To regain a proper connection I have to power down the BLE device, remove the device from the device list, power up the device, search for Bluetooth devices, then add it back. The process doesn't take very long, but this is being used in a live performance and that sort of interruption is quite disruptive.

I'm also unable to automatically connect when the computer is powered on.

I've tried removing all Bluetooth related items in the Device Manager to no avail.

My question is, where do I begin troubleshooting this? Is there a software tool I can use to tell me if it's still connected and sending data? I'm not sure if it's a Bluetooth LE issue, a hardware issue, or if it's something else in the software path.

Here are some of the particulars:

  • OS: Windows 10 Pro, Ver 1809, Build 17763.437
  • Computer: Lenovo ThinkPad X130e
  • USB BLE Receiver: Tripp Lite U261-001-BT4 (Uses CSR8510 A10 Chipset). Using this because the computer's internal Bluetooth is not BLE compatible.  I have the internal Bluetooth turned off in the BIOS.
  • Device: Yamaha MD-BT01
  • Software to create the MIDI bridge: LoopMIDI, MIDIberry 1.1.0

Update 4/24/19 Did a lot of testing last night on two different laptops both running the same version and build of Windows 10 Pro. One computer used the Tripp Lite USB Bluetooth adapter, the other used an internal adapter. The results were identical between the two computers.

Here's a scenario of interest...

  1. Power up computer.
  2. Power up MD-BT01.
  3. Go to Bluetooth Settings, Add MD-BT01 device. Device is added with a "Paired" status
  4. Run loopMIDI
  5. Run MIDIberry and make connections. MD-BT01 now has a "Connected" status in the Bluetooth Settings window.
  6. Send MIDI data and verify connection works via MIDI monitor in MIDIberry.
  7. Power off MD-BT01
  8. MD-BT01 still has a "Connected" status in the Bluetooth Settings window.
  9. Power on MD-BT01
  10. MD-BT01 still has a "Connected" status in the Bluetooth Settings window.
  11. Send MIDI data
  12. Notice NO data is received in MIDIberry.
  13. Close MIDIberry
  14. MD-BT01 goes from "Connected" to "Paired" in the Bluetooth Settings window.
  15. Run MIDIberry
  16. MD-BT01 goes from "Paired" to "Connected" in the Bluetooth Settings window.
  17. Send MIDI data and verify connection works via MIDI monitor in MIDIberry.

So, by closing then reopening MIDIberry it appears the connection is reset and MIDI data flow has been reestablished. At this point it appears to be more of a MIDIberry issue than a BLE issue.


Update 4/29/19

I sent a message to the makers of MIDIberry. Their statement was:

"The problem occurs because the Windows 10 BLE stack can not get the MIDI device’s power state. There is nothing we can do."

  • Its Win 10 bug. Try to update tothe latest version. Or use software that does not need to pair (add) with your device. – Mike Petrichenko Apr 23 '19 at 18:11
  • Updated to latest as of 4/23/19. Edited original statement to include OS info. – Rich G. Apr 24 '19 at 2:43
  • Please, try this: once you faced the issue try to remove USB Bluetooth dongle from your computer. Open Device Manager and check if Bluetooth drivers (device) is still presents even it is removed. If it is still there - this is Bluetooth drivers bug. If it is disappeared then we can try to resolve this. – Mike Petrichenko Apr 24 '19 at 3:29
0

This may be a problem with the driver.

The Tripp Lite page Mini Bluetooth 4.0 (Class 1) USB Adapter Contains these drivers:

You may also from this page register your device for a 3-years warranty (if not too late).

The release notes for version 2 contain this method for distinguishing between the two versions:

To determine which version of the U261-001-BT4 you have, check to see if your unit has a SKU number printed on the back of the unit. If you see the SKU number CU885A printed on the back, you have v2 that requires BlueSoleil. If you see anything else, you have v1.

The v2 driver will install the BlueSoleil Bluetooth stack, so you will not be using the Microsoft stack (but you may always return to using the Microsoft stack).

  • I have the V2 adapter. I tried the whole BlueSoleil route, but could never get it to work at all. At least with the Microsoft stack it works when I add the MD-BT01 to the device list. On top of that, the BlueSoleil software is a data limited trial version. I've been down the road of TrippLite tech support... which is why I'm here where the real pros are. ;) – Rich G. Apr 23 '19 at 18:54
  • Flattery, flattery ;) If the problem is with the Tripp Lite built-in firmware, I don't think that there is an update for that, if the device just doesn't detect that the connection was broken and keeps on using the dead one. Why does the connection break? This shouldn't happen for a dongle. – harrymc Apr 23 '19 at 19:05
  • Why does the connection break?... could be monetary power loss, out of range, blocked signal (line of sight path interrupted), RF interference. – Rich G. Apr 23 '19 at 20:23
  • Power loss for dongle means computer down. Interference would cause frequent problems. Is this happening a lot or very infrequently? – harrymc Apr 23 '19 at 20:40
  • The computer stays powered and thus the TrippLite Adapter stays powered. The MD-BT01 plugs into a MIDI controller that sits on the stage. It's currently susceptible to having its power interrupted... someone might kick the power cord, battery might die, falls out of socket. As much as we try to design against things like this happening, they can and do happen. When it does happen, things need to get back running quickly. Having to spend 5 mins reconnecting bluetooth software connections can seem like an eternity. – Rich G. Apr 23 '19 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.