1

So I have 3 drives in my PC: 1 system, 1 backup, 1 storage.

I'm trying to add the contents of the storage drive to the Windows 10 indexing service, but when I go to Index Options, the drive is not listed anywhere: it's not under "index these locations", so I hit the "Modify" button, and the drive is not listed under "Change selected locations". So then I hit "Show all locations" button and, again, the drive is not listed under "Change selected locations". So I hit cancel. Frustrating.

I have checked the drive security permissions and they are the same as the other drives.

I really need this drive to be indexed, help me figuring this out please

0

As it turns out, my Windows 10 was not recognizing my storage drive as a fixed drive, and was considering it a removable drive. Here is how I determined the problem and found a fix:

  • First I found an online guide suggesting a drive letter change fix. I did that, and as I changed the drive letter, a windows notification popped up asking me what to do when a removable drive is connected to the system. I thought that was strange. Switched back to the regular drive letter I use and, again, the same notification popped up.

  • Suspecting the drive was not being properly recognized as fixed, I checked the indexing locations again under Indexing Options, recalling that I kept seeing a folder displayed with a long ID string, and a tooltip informing me that that particular location was unavailable. I never assumed this to be a problem since I also have USB drives plugged in/out sometimes:

tooltip

  • PROBLEM FIX: to set the drive to be seen by windows as permanently fixed follow Microsoft's own guide here: https://support.microsoft.com/en-us/help/3083627/internal-sata-drives-show-up-as-removeable-media

  • If for whatever reason the command mentioned in the MS guide doesn't work follow these steps below

    1. open Registry Editor in administrator mode
    2. browse registry folders to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
    3. add a new "Multi String Value" called "TreatAsInternalPort" and list the bus number for the drive in question:

new registry value

  1. it should look like this once you are done: Registry edited

  2. reboot and check Indexing Options again, you should now see your drive on the selection list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.