0

I'm concidering syncing files between 2 OSX machines(MBPs) with rsync.

After installed the newest rsync(3.1.3 I checked) on both MBPs by homebrew, I tried following command on the old MBP:

rsync -vahEPzXe ssh foo bar@newMBP.local:~/.

But it returned:

rsync: on remote machine: -vlogDtpXrze.iLsfxC: unknown option
rsync error: syntax or usage error (code 1) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-52.200.1/rsync/main.c(1337) [server=2.6.9]
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.3]

Then I dropped -X option, it worked.

rsync -vahEPze ssh foo bar@newMBP.local:~/.
...
sent 1.29G bytes  received 197.52K bytes  12.62M bytes/sec
total size is 1.66G  speedup is 1.28

I use tags to manage files, and they are not preserved without -X option, so now I'm in trouble.

Can anyone help me fix that or suggest any other ways to sync tag information?

Thanks!

1

That sounds like it's running the built-in rsync (v2.6.9), which does not support -X (it does support transferring extended attributes, but using a different and incompatible format). You can force it use v3 on the remote side with something like --rsync-path=/usr/local/bin/rsync (or whatever the correct filepath for v3 is on the remote computer).

  • I'm very sorry for the late reply. This answer completely fixed my problem. Thank you. – anricc Nov 13 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.