I'm working on a corporate desktop (still) running Windows XP SP2. I recently received a new PC and am reinstalling all my tools. Something is different about this one in that it won't let me install Powershell 2.0.

When I do, I get a popup:

You do not have permission to update Windows XP. Please contact your system administrator.

This also occurs for other installs, like Service Pack 3 and Windows Installer 4.5.

I'm aware this PC is under group policy restrictions, but I haven't narrowed down what restriction is preventing this install so that I can have the appropriate support team resolve it. What setting could be responsible for this?

  • 1
    Sounds to me like this question could be better answered on Server Fault. I'm voting to migrate there, but I could be wrong, that's only my opinion. – Gnoupi May 19 '10 at 15:43
  • I was on the fence about onto which site to post. Since the subject matter is Windows XP, I came here. – spoulson May 19 '10 at 18:16
  • are you sure your an admin on the workstation? – user33788 May 19 '10 at 21:08
  • Yes, I am a local admin on the workstation. I can install most other software without this restriction. – spoulson May 20 '10 at 11:52
  • The fact that the question is about XP doesn't mean it has to be on Super User. – ChrisF Jun 26 '10 at 20:19

Have a domain admin install it with their credentials. If that works, great - it's working, and you've demonstrated to the admin that the group policy needs some refinement. If it doesn't work, even better (sort of), in that you will have demonstrated that there are SERIOUS issues with group policy. Regardless, I agree that this should be on Server Fault as I think it's unlikely to be a workstation issue.


I see this is an old thread, but for anyone else that comes here, this site helped me:

After some poking around I found that the local Administrators group did not not have Full Control of the registry key HKLM\Software\Microsoft\Windows NT\CurrentVersion\Svchost to which it was trying to write.


Check MS KB 888791. Some updates Powershell among them require certain rights.

Check the computer policy that the account has the following rights:

Backup files and directories, Debug programs, Manage auditing and security log Restore files and directories Shut down the system Take ownership of files and other objects.

If any of these rights are missing, you will get that message.

See: http://www.definit.co.uk/2009/01/windows-update-or-installer-fails-to-install-with-error-you-do-not-have-permission-to-update-windows-server-2003-please-contact-your-system-administrator/

Basically, add the rights, and run gpudpate /force. Try to install again.

I think there may be a 'run as' issue here because unfortunately, you may have all those rights, and it may still fail. I get this error via "run as" with the install file because my given server requires a logged on user with non-admin rights, so I am forced to resort to this or schedule a reboot notifying of down-time. Are you using "run as" as well?


Powershell 2.0 requires Win XP with Service Pack 3.

WinRM 2.0 and PowerShell 2.0 can be installed on the following supported operating systems:

  • Windows Server 2008 with Service Pack 1
  • Windows Server 2008 with Service Pack 2
  • Windows Server 2003 with Service Pack 2
  • Windows Vista with Service Pack 2
  • Windows Vista with Service Pack 1
  • Windows XP with Service Pack 3
  • Windows Embedded POSReady 2009
  • Windows Embedded for Point of Service 1.1
  • Windows PowerShell 2.0 requires the Microsoft .NET Framework 2.0 with Service Pack 1.

Source: Windows Management Framework (Windows PowerShell 2.0, WinRM 2.0, and BITS 4.0)

  • When installing SP3, I get the same error message. Back to the original question... – spoulson May 19 '10 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.