9

Since yesterday google chrome have been running in dark mode. As far as I understand, this is due to a new update which makes chrome follow the mode of my default app mode. When I google for an answer most of the questions is about how to enable dark mode, but not many about how to disable it or force light mode.

I'm running on windows 10 with dark mode as default app mode and I intend to continue doing so, so changing to light theme isn't the solution here. I have tried changing the theme on chrome but the url bar is still in black so that would be the last solution.

I've seen a number of command line switches on peter.sh but those are intended for chromium, not google chrome (I know that they share many similar switches but they are not completely identical). I saw that there is a --force-dark-mode but it seems like there isn't any --force-light-mode.

Can I find an updated list of google chrome command line switches somewhere else, or any other solution that might work?

Thanks in advance!

2
  • Perhaps you should try what you found for Chromium. It's the (open-source) base code for Chrome, the only difference being the latter has some Google proprietary code added. For such basic operations what works in Chromium should work in the same version Chrome.
    – user931000
    Apr 26 '19 at 17:32
  • @GabrielaGarcia Hi! I did look through the list some times but couldn't find any switches that gives the desired result. Also this is a single persons website, doesn't google have any documentations covering this? I can't seem to find any.
    – kebbaben
    Apr 27 '19 at 7:30
3

As of the version 76.0.3809.100, this solution doesn't work anymore. (1),(2)


I took a look at this issue in Google Support and found this answer:

Add to Chrome shortcut properties target: --disable-features=DarkMode

So the entire target looks something like: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=DarkMode

Do this to your desktop shortcut (and unpin/repin the icon in the taskbar to get the updated shortcut) and it should be light while Windows is still in Dark Mode.

9
  • 1
    Thank you, this works! I had some issues with it not starting correctly due to me starting chrome from taskbar. Just unpinned and repinned it and it worked perfectly!
    – kebbaben
    May 5 '19 at 10:55
  • @kebbaben Nice, glad it worked!
    – CaldeiraG
    May 5 '19 at 15:22
  • 1
    It seems that google have once again changed something for the worse and now the command line switch doesn't work since this morning. Do you have any other ideas of how to to fix this problem?
    – kebbaben
    Aug 7 '19 at 7:42
  • @kebbaben hey, it appears it's not only you. I'll have a look again and I come up with something I will edit the answer
    – CaldeiraG
    Aug 7 '19 at 7:59
  • Then as this doesn't work anymore I'll have to revoke the accepted answer until a new one has been provided.
    – kebbaben
    Aug 8 '19 at 12:54
1

Currently I've found no real solutions but a few workarounds that I will put here for reference.

Set default app mode to "light"

The workaround I'm currently using is setting the default app mode to light. It's exactly what I don't want to do in order to fix this, but it's my best choice for now.


Download a Google Chrome theme

If you still want to have the default app mode set to dark, you can install a white theme to google chrome. This isn't really the best workaround. While it does give you a light mode chrome it also leaves your URL field completely dark.


Use a different web browser

This isn't really a workaround but choosing a different browser might relieve you from the fear of Google's scary whims. As I said "This isn't really a workaround" but sometimes many problems can be solved by switching browsers.


Use the --disable-features=DarkMode switch

Possibly the worst workaround is reverting to chrome to any version prior to version 76.0.3809.100, disable auto-updating and adding --disable-features=DarkMode to the shortcut used when starting chrome.

The target string should look like this "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=DarkMode. Of course the path itself will be different if you've installed chrome elsewhere.

The reason why this is possibly the worst workaround is because it not only leaves you without newer updates to chrome, but it's also a big security risk. Google actively push out security updates to their browser and without them you're more vulnerable to malicious attacks.


I won't mark this as answer as it doesn't propose a solution yet. I will add more workarounds (and hopefully a solution) here as I come across them.

1
  • That white theme did the trick! Jun 3 '20 at 7:25
0

I solved this problem by going to Go to windows setting > colors > Custom and then I chose Dark for default Windows and Light for Windows App.

1
  • 1
    Read the question before posting an answer. In my question I wrote: I'm running on windows 10 with dark mode as default app mode and I intend to continue doing so. Even if it solves your problem, this answer is not a solution to this problem.
    – kebbaben
    Jul 9 '19 at 6:26
0

In the Chrome address bar enter the following:

chrome://flags#enable-force-dark

Then, for the option ensure that option "Disabled" is selected. After the change your browser will ask you if you want to restart - do so.

-2

I have same problem as well.

It's about your windows setting. Go to windows setting > colors > choose your default app mode to "light", then go back to chrome, it should change back to the original light mode.

But of course it means your windows can't have dark background of course. For your reference, now I choose to stay in dark for windows setting, and change the chrome theme to "pro grey', it a compromise for me.

change the setting from dark to light

2
  • 1
    this doesn't answer the question in any way
    – phuclv
    May 4 '19 at 5:31
  • @lee Please read the question before answering: "I'm running on windows 10 with dark mode as default app mode and I intend to continue doing so"
    – kebbaben
    May 5 '19 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.