1

My Windows 10 keeps trying to auto repair, and fails loading.

Important note: I used to change motherboard since I initially installed the Windows. Maybe this hardware change is related?

From what I read this could be related to Windows fast hibernation.

Windows partition can only be mount under Ubuntu as read only.

Reset this PC option fails saying drive is locked.

It fails on following BSOD (since I recently disabled the "Automatic repair" in UEFI).

enter image description here

Translated sentence is:

Failing booting OS, as a critical system driver is either missing or corrupted.
File: \Windows\System32\drivers\stornvme.sys
Error code: 0xc000000f

This message is the more precise I had until now, and is about a stornvme.sys missing, or corrupted file.
Indeed, this file does not exists under C:\Windows\System32\drivers.

Should it exists? If so, could it be recopied from somewhere? (installation media, internet?) (I am not sure if "NVME" is about M2 drive, but I do not have M2, rather a standard SSD drive).

This file was also indicated in a log pointed during auto repair loop. (/Windows/System32/LogFiles/Srt/SrtTrail.txt with a 0x490 error code).

Cause initiale trouvée :

Le fichier critique de démarrage c:\windows\system32\drivers\stornvme.sys est endommagé.

Action de réparation : Réparation de fichier Résultat : Échec de l’opération. Code d’erreur = 0x2 Durée = 1485 ms

Action de réparation : Vérification et réparation de l’intégrité des fichiers système Résultat : Échec de l’opération. Code d’erreur =
0x490

(in SrtTrail.txt)

It is a dual-boot configuration which you can have some more detail in this askubuntu topic.

After trying to understand what happens, I tried a lot of differents solutions, but none worked:

  • bootrec.exe /rebuildbcd, bootrec.exe /fixmbr, bootrec.exe /fixboot

  • chkdsk /r c: or chkdsk C: /f /x /r (in the later, I noted the filesystem to successfully be detected as NTFS, and chkdsk works with no issue)

  • following this topic, I ran sfc /scannow with failing with (translated from French):

    Windows resources protection could not make the asked operation

enter image description here

  • when attempting to "Update this PC" using the installation media, it fails with:

    Drive where Windows is installed is locked. Unlock it and retry

  • when attempting to "Reset this PC" using the installation media, it fails with:

    Cannot reset PC. A required partition is missing.

  • tried to disable Windows Hibernation from troubleshooting boot command line, but failed: powercfg -h off. Below (translated) message says (because not run from Windows?):

    Command failed: this operation is not handled

  • tried to rename some Windows System32 files: ren system.001 system and ren software.001 software and restart, no change

  • disable windows auto repair with command bcdedit /set {default} recoveryenabled No (solution 3 from here). After this, I no longer have the "Preparing auto repair loop", but BSOD directly appears.

  • restore a copy from C:\Windows\System32\config\RegBack\*.* to C:\Windows\System32\config (solution 4 from here)

  • again, play with bootrec but from the installation media. Last command bootrec /rebuildbcd is the only one failing, saying (translated):

    The requested system device is not found

enter image description here

last thing I tried is bcdboot with no change (as from here):

diskpart
sel disk 0
list vol
sel vol 2 (the one in FAT32)
assign letter x:
Wait for the confirmation message from the diskpart utility to appear:
DiskPart successfully assigned the drive letter or mount point.
exit
cd /d x:\EFI\Microsoft\Boot
bootrec /fixboot
ren BCD BCD.Backup
bcdboot c:\Windows /l fr-FR /s x: /f ALL
exit

After I read Windows 10 won't boot after the UUID of the EFI partition changed - Error 0xc0000225, I wonder if it could not be such a UUID issue since I changed of motherboard.
How could I ensure or verify this?

I opened the /boot/grub/grub.cfg file, but everything looks ok, but I am not a super user of this kind of things, so I would not be able to point out an error.

Any help, clue is welcomed.

  • The driver stornvme.sys is the interface to NVMe drives. Have you while replacing the motherboard, moved Windows to an NVMe drive that didn't exist before and this is your first boot? – harrymc Apr 27 at 12:22
  • No, Windows remained the same and was installed on a SATA (thus not an nvme drive?). i never had nvme drive installed. – el-teedee Apr 27 at 16:30
  • If you don't have any NVMe drive but Windows aborts, and you cannot do In-place Upgrade, you might need to reinstall Windows. – harrymc Apr 27 at 16:49
  • I don't have, and I can't in-place upgrade (what I wrote "refresh" or "reset" ?), failing either on "drive is locked" or "required partition" is missing. How to know if locked, or some partition is missing? – el-teedee Apr 30 at 9:48
  • You might use a Linux live USB to check what's happening with the partitions on the disk. – harrymc Apr 30 at 9:51
0

I ended up by reinstalling windows after deleted all partition

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.