0

I'm very new to using Homebrew and Nodejs in general, and have been having a lot of difficulty installing Nodejs via Homebrew on my Mac.

Whilst installing node via the terminal, the persistent error I'm seeing is the following:

'Error: Could not symlink include/node/common.gypi'

I've tried various fixes specifically the following commands, without success:

brew link node - to which I receive the following output:

' henrybrenton@Henrys-MacBook-Pro /usr/local/include/node

$ brew link node

Linking /usr/local/Cellar/node/11.14.0_1... 

Error: Could not symlink include/node/common.gypi

Target /usr/local/include/node/common.gypi

already exists. You may want to remove it:

rm '/usr/local/include/node/common.gypi'

To force the link and overwrite all conflicting files:

brew link --overwrite node'

This returns the previously mentioned error:

'Error: Could not symlink include/node/common.gypi'

Having researched on google and youtube, combinations of other commands I've tried include:

-brew doctor -brew cleanup -brew link node -brew uninstall node -(then, after then above) brew install node

Please advise - any help in understanding this issue, and resolving it would be greatly appreciated,

Many Thanks

Henry

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.