0

Sometimes when I resume a virtual machine, the date and time continues from where it was when I paused the VM.

This causes some issues with cookies, tokens, and other things.

Is there any way I can force the VM to look at the date and time of the host machine and synchronize?

  • What is the guest OS? Different virtualized OSes may behave differently. As well, what virtualization software are you using? – bjb Apr 29 '19 at 17:10
  • It's a Windows 10 guest on a Windows 10 host. The vm software is VMWare 14 Workstation (see tags) – CodyBugstein Apr 29 '19 at 17:10
  • If you have VMware Tools installed in the guest, this should happen automatically after resuming the VM. – jamesdlin May 2 '19 at 15:25
  • @jamesdlin It doesn't though. That's what's odd – CodyBugstein May 2 '19 at 15:27
  • Verify that the "Synchronize guest time with host" is checked under the VM's Settings-->Options-->VMware Tools – essjae May 2 '19 at 21:44
0

The problem was occurring when I paused my VM while a debugging process in Visual Studio was running. It seems the running process blocks and synchronization of the time.

To solve this I stopped the process and paused the machine. Then when I resume, the time is correct.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.