0

I have a fresh install of Server 2016. I have WSUS installed on it as an offline WSUS server. I have a few systems connected to this WSUS server to update all my computers.

Both my Windows 10 machines and Server 2016 machines connected to this server fail to update with error 0x80246002. This is after they detect the updates they have to do; they download the file and then give me this error. I have tried to do a full WSUS reinstall, but still get the same error.

When I run the Windows update troubleshooter on the clients. I get one that is NOT FIXED.

"Potential Windows Update Database error detected"

I have stopped the Windows Update servers and Changed SoftwareDistribution to SoftwareDistributionOLD and restarted the service; the same issue persists. As much as I can tell this is issue is a mismatch between hashes on downloaded files. Not sure how I can test that or correct it.

Has anyone had this issue before?

UPDATE: Ran all the suggested fixes and I am still getting these errors on all the computers in the domain.

11832 11992 DownloadManager *FAILED* [80246002] Failed to postprocess the file: URL = 'http://xxxxx.xxxxx.xxxx:8530', Local Path = 'C:\WINDOWS\SoftwareDistribution\Download\388cc9a8175bea9582e317d3f93a3d5\windows10.0-lb4486553-x65.cab'
11832 11992 DownloadManager *FAILED* [80004001] Method failed [CAgentDownloadManager::CanRetryWithDifferentCDNForError:23965]
11832 11992 DownloadManager *FAILED* [80246002] Error occurred while downloading update 466B908E-25B0-4278-81EA-EED46C8170AD.202; notifying dependent calls.
11832 8140 Misc *FAILED* [80070003] Method failed [SusMoveOrCopyDirectoryContentHelperRecursive:1648]
11832 8140 Misc *FAILED* [80070003] Method failed [SusMoveOrCopyDirectoryContentsHelper:1728]

3 Answers 3

1

I had a similar problem recently and in my case, the WSUS server was not part of the domain. I configured the WSUS GPOs to point to the IP Address of the WSUs server, but aparrently, after scanning, the WUA on the clients gets a list of updates to download, with the download URIs provided by WSUS - which were using the WSUS hostname, instead of the IP address. So the domain computers were unable to find from were to get the updates. I created in DNS an entry for the WSUS hostname and after that, the updates started to download and install. I see that you said the files were downloaded in your case, however, also in my case the same error appeared, and the associated error message was mentioning a failure to install, not to download, when in fact the files were not downloading.

I would suggest to copy the URI of a file from the WSUS interface (File Information), then to try on a client with failures to copy the file using this URI inside a browser.

3
  • 1
    Can you give some idea on how to do this?
    – JukEboX
    Aug 2, 2019 at 13:11
  • I actually browsed for the file on the WSUS server guided by the File Information details, then composed the URL, as I could not copy directly from WSUS. But the principle is to see if whatever file location is provided by WSUS is reachable from any affected client.
    – Narcis
    Aug 5, 2019 at 19:38
  • I have gone to the URI and I can download the files of each update. Not sure what the problem is now.
    – JukEboX
    Aug 22, 2019 at 18:24
0

Stumbled across the answer to this on my system when I was troubleshooting dual scan. Set the Download Mode for Delivery Optimization to LAN(1) and now they all are working and downloading correctly. If ones were still stuck there I had to do the Replacement of the SoftwareDistribution and the Catroot2 folder get it back to order. Dual scan must have been reaching out to the computers on the network for the files instead of the WSUS server.

-2

The following article describes various methods to fix a corrupt Windows Update database and/or service:

https://pureinfotech.com/reset-windows-update-windows-10-fix-downloads-installs/

4
  • I have run the Windows Update troubleshooter already as stated above. I have the most recent Windows 10 Feature update. I have the most recent Servicing Stack. DISM shows no issue with the image.
    – JukEboX
    Apr 29, 2019 at 20:19
  • There are many troublshooting tips in that article. Have you tried them all? 1 - Run DISM tool 2- Run System File Checker 3- Run Windows Update troubleshooter 4- Reset Windows Update components 5- Perform a Clean boot Apr 29, 2019 at 20:28
  • I am running some now. Stay tuned.
    – JukEboX
    Apr 29, 2019 at 20:36
  • Tried all 5 suggestions. None of them worked for ANY of my computers.
    – JukEboX
    Apr 29, 2019 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .