1

I'm having a problem with an Asus laptop. Running Windows 10, WiFi connection is OK but it seems unable to access internet.

It started to fail suddenly, and it has been gone since.

Things tried:

  • Forget and connect again to the WiFi Network
  • Change IP to static inside the LAN configuration.
  • Change DNS to Google's.
  • Connect through Ethernet (internet works).
  • Connect to a WiFi iOS hotspot (internet works, so WLAN card is fine).
  • ping to default gateway (went fine).
  • ping to 8.8.8.8 (went fine).
  • nslookup to www.google.com (went fine).
  • ping to www.google.com (went fine).
  • Reset winsock, emptied and flushed DNS cache.
  • Scanned for viruses (all OK).
  • Restored to a previous system savepoint.
  • Upgraded WLAN card drivers through Device Manager when connected to WiFi hotspot.
  • Used System Restore to set the PC in as-bought state.
  • Formatted and reinstalled a fresh Windows 10 through an USB drive.
  • Checked MAC filter in the router (it's disabled).
  • Checked "Internet Options" for TLS settings and set the security level to Medium.

Everything listed as went fine kept working after the Windows 10 fresh install.

Yeah, it's, at least, weird. We know that Windows can access internet because ping works, and DNS works too, nslookup says it. The WLAN card is fine because we can browse the internet when connected to a Wi-Fi hotspot.

Does any of you know what to do? Thanks in advance.

Info:

  • Windows 10 version: Windows 10 Home 1809
  • WiFi card: Atheros ar956x
  • Drivers used: Installed by Windows Update, worked fine everytime before.
  • Please edit your question and indicate which version of Windows 10 you are using. You should also specify what WiFI adapter you are using and if the drivers for it specifically support the version of Windows 10 you are using. You should also indicate if you have attempted to reset the access point's configuration. – Ramhound Apr 29 at 20:45
  • 1
    Thanks @Ramhound, I just edited the question. – Pedro Adame Vergara Apr 29 at 20:56
1

Ok, just solved it...

After two weeks with this problem... I restarted the WiFi router and boom, working.

Oh my god.

I don't know if someone could give an explanation, but would be useful. Didn't suspect about the router because everything else was working through Wi-Fi (smartphones, nintendo Switch, etc).

  • 3
    Your router is likely running a Linux kernel. Unless you want to go sorting through logs, which might not exist depending on the router's configuration, the "why" cannot be answered by anyone here. – Ramhound Apr 29 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.