1

As I am having this problem for the second time already, I want to post my own solution here so I can just look it up next time.

Im using a HP Eliteobook on which I did a clean Windows10 installation after receiving it. After that clean install I got this error described here which I solved back then. Now, after upgrading to Windows 10-1809 the same error pops up again:

[Window name] HP Hotkey UWP Service

Error: HP Software Framework is not installed in the system
Please download and install from the link -
ftp://ftp.hp.com/pub/caps-sofpaq/cmit/softpaq/CASLSetup.exe
Note: Restart system after installation

so, the link they provide is not even valid anymore, and I have absolutely no intention of re-installing HP bloatware anyway. There are some people in the HP forum thread I referenced above that report using other HP software like "HP Support Assistant" solved their problem. However I don't have all these available since I did a clean windows installation.

1

So before in- or uninstalling anything I checked the notebook's keyboard and tried all the F1-F12-keys (that without pressing Fn all have different functions - I believe those are what HP means by hotkeys). I checked if they do what they're supposed to do and I couldn't find any "hotkeys" that don't work.

If this is the case the solution is very simple:

  1. open "Services"
  2. find the entry "HP Hotkey UWP Service"
  3. right click on it -> stop
  4. right click on it -> properties -> set startup type to "disabled"
|improve this answer|||||
0

I got the same message when trying to up the brightness after uninstalling some bloatware. (and possibly, accidentally, one application that I actually needed)

What worked for me was going into the HP recovery manager and through 'reinstall drivers and/or applications' reinstalling 'HP hotkey support'.

If you don't have the recovery manager installed you might be able to find a download online.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.