1

I have Windows 10 Home running on a Toshiba Satellite laptop.
Current windows version is 1803 OS Build 17134.523.

I do not think I have Developer Mode enabled but I will check to confirm.
UPDATE: So, in the "For Developers" section I have "Sideload Apps" configured. It is not in Developer Mode.

UPDATE LATEST: I've just realised that windows update history includes error codes.
So, going backwards in time from latest:
KB4493464 failed with 0x80070643
KB4346084 failed with 0x800f0922
KB4493437 failed with 0x800f0922
KB4489868 failed with 0x800f0922

Windows Update itself tells me I up to date.

MORE UPDATE Setupdiag has this log file:

Matching Profile found: MigrationAbortedDueToPluginFailure - D07A24F6-5B25-474E-B516-A730085940C9
System Information:
Machine Name = DEV-PC
Manufacturer = TOSHIBA
Model = SATELLITE P50-C
HostOSArchitecture = x64
FirmwareType = UEFI
BiosReleaseDate = 20150415000000.000000+000
BiosVendor = 1.10
BiosVersion = 1.10
HostOSVersion = 10.0.17134
HostOSBuildString = 17134.1.amd64fre.rs4_release.180410-1804
TargetOSBuildString = 10.0.17763.107 (rs5_release_svc_prod2.181026-1406)
HostOSLanguageId = 2057
HostOSEdition = Core
RegisteredAV = Windows Defender,Windows Defender,Windows Defender,Windows
Defender,Windows Defender,Windows Defender,
FilterDrivers = FsDepends,PSINProc,PSINFile,wcifs,luafv,Wof,FileInfo,
UpgradeStartTime = 02/05/2019 22:57:15
FinalizeStartTime = 02/05/2019 23:26:38
UpgradeEndTime = 03/05/2019 07:47:55
UpgradeElapsedTime = 08:50:40
CV =
ReportId =

Error: SetupDiag reports fatal migration plug-in failure.
Setup Operation: Gather data, scope: EVERYTHING
Plug-in Error: 0x00000422
Plug-in Name and Action = Action,CMXEPlugin,C:\$WINDOWS.~BT\Sources\ReplacementManifests,Microsoft-Windows-AppX-Deployment-Server\AppxUpgradeMigrationPlugin.dll,{AE27C1A6-25F2-45FD-9A28-081B81F29E0A},Apartment.

I'm now searching for what this means.

For some time I have been unable to have a Windows update complete successfully - for example, these are the latest updates have failed:
KB4493464
KB4346084
KB4493437

Following the instructions from Microsoft for fixing windows update issues I have:

  1. Tried installing Windows 10 v1809 from online updater - failed
  2. Ran Windows Update Troubleshooter - fixed errors. Re-ran update - failed
  3. Update SSU - already have latest version.
  4. Installing KB4493437 - failed
  5. Run DISM and SFC - completed without errors
  6. Run Windows Update - failed
  7. Run "in place upgrade" using Media Creation Tool - failed
  8. Done a clean boot and run the updates then as well

When the "in place" upgrade fails, it gets to a point where it needs to do a restart and then a dialog pops up telling me that windows update has failed.

According the MS support I'm now faced with simply doing a clean install of Windows 10 v1809 but I really don't want to do that.

I can see errors in the Application and Setup event logs but I'm not sure what to look for. I can also see lots of messages in the log file C:\Windows\Logs\CBS\CBS.log but again I'm not sure what I'm looking for.

I will update this question with more information if I find any useful tips on what errors to look for.

UPDATE: I had MS tech support logged in to my PC last night for 3.5 hours and it still doesn't appear to be fixed.
The support tech told me that the upgrade that always failed was apparently for ARM based systems - KB4493464 I think. However, he was unable to explain why my PC was trying to install this update.
He then tried running an in place upgrade to 1809 which again ended in a dialog box stating "Windows update has failed."

I will look through the logs this evening to see if I can find anything useful.

  • 2
    What error code do you get when it fails? You could also post somewhere CBS.log for us to have a look. – harrymc Apr 30 at 20:42
  • 1
    @harrymc So far I haven't seen an error code. Either a message telling me the upgrade is being rolled back or just a dialog telling me it failed. CBS log is filled with data - how do I locate windows update entries? – Matt Jones Apr 30 at 20:59
  • 1
    Search for entries with "Error" and add them to your post. Some people report success when enabling the built-in Administrator account and running under it. – harrymc Apr 30 at 21:04
  • Can you confirm what version of Windows 10 are you running? Please provide this necessary information in the body of your question. Do you have Developer Mode enabled? If you do have it enabled, you need to disable it, then proceed with the upgrade to 1809. "Run Windows Update - failed" - You are going to need to provide more information than this. – Ramhound Apr 30 at 21:22
  • 1
    KB4493464is 17134.706 and KB4493437 is 17134.753 you only need to install KB4493464. Do not attempt to install KB4493437 it serves no purpose, it is not the current cumulative update, and you will only end up having to install KB4493464. KB4346084 is the Spectre Intel microcode update. I would attempt a Windows Update Reset and provide all helpful information that follows after doing that. Without details and specifics, your question cannot be answered. – Ramhound Apr 30 at 21:26
0

This issue was caused by the WSAPPX service being disabled. Once enabled and running again, I was able to successfully run the update and now my PC is on v1903.

I had manually disabled the WSAPPX service due to it causing 100% disk usage - I had done this by manually editing the registry for this service. I had gone to the HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AppXSvc and changed the value of the Start to 4. This prevent WSAPPX from starting. I'd found this hack listed on several sites that attempted to solve the high disk usage issue with WSAPPX, something which seems quite common.

One of the symptoms was Windows Store being unable to install apps and not showing any updates (when trying to install apps, I got an error saying Windows Update was disabled, which was confusing to say the least).

I changed the value back to 0x20 and rebooted my machine. When checking Windows Store it correctly showed my apps and I was able to install some.

I then ran the Windows update and it completed successfully, bringing my OS version to v1903.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.