I have this XPS laptop since a year and a half ago. About 2 months ago, with the waranty expired, i tried to run the optiarc slot load DVD-RW firmware update, and said everything was okay. Then I restarted it and the problem started:

Now, every single time I turn on my computer, it get stuck at the BIOS POST until the drive sounds like "ready" and then the computer starts normally. And this happen EXACTLY the same when it's getting back from sleep.

I'm pretty sure is not a software issue, because I tried with Vista Home Premiun 32 bits, Ubuntu (from 8.10+)32 & 64, and with W7 64.

Already tried to run the firmware installer like a million time, in case it is a failing install with no luck. Also, google it to see if someone has the same problem, and again, no. The Drive performs pretty okay once the System is on, but waiting to the drive to be ready everytime is really annoying.

The Firmware I updated was this, and the drive is:
K937C Assembly, Dvd+/-rw, 8, SLOT, 1530 Sony Nec Optiarc Inc.

I'll apreciate any help you can give me

UPDATE: I had to disable the drive on BIOS to get the laptop to turn on quickly, so this is the prove that is a Drive problem, I think

  • Good job on the initial triage. – kmarsh May 21 '10 at 12:30

It might be a corrupt file that you used, try and download it again from here, then do a md5-sum check of your file (R193620.EXE) and compare with my results below. If you get the same md5-sum, follow the instructions provided by dell and reflash it.

MD5 (Downloads/R193620 (1).EXE) = aa6d86adcc7b7e923034e59314f911e9
MD5 (Downloads/R193620(2).EXE) = aa6d86adcc7b7e923034e59314f911e9
MD5 (Downloads/R193620.EXE) = aa6d86adcc7b7e923034e59314f911e9

Also make sure you have the latest updates to your BIOS etc.

  • Thanks for the reply. The md5-sum result from my downloaded file was AA6D86ADCC7B7E923034E59314F911E9 R193620.exe, looks that is the same (using the program I downloaded from fourmilab.ch/md5 ), and tried again to flash the drive, with a recent clean install of windows 7 x64 and everythings is again, the same The OS on I'm Flashing will make any difference? – josecortesp May 21 '10 at 17:40
  • It says on Dell's page that the flash utility is only compatible with Microsoft Windows Vista 32-bit/64-bit & Microsoft Windows XP/XP x64 so that might be it. Try flashing from good ol' XP 32-bit. Also remember to check your cables, that they are properly connected and not broken in any way. If you have other cables to try with, do that. Ah, right. It is a laptop...still check the connections if you can. If you feel adventurous and have a desktop PC you could try and put the drive in the desktop PC and do it from there. But beware, opening and closing a laptop can be kind of tricky. – Johan Allgoth May 25 '10 at 12:13
  • Will it may work with XP mode? or it'll be the same? (sorry to this late reply, but I just saw your comment... Thanks BTW!! ) – josecortesp Oct 3 '10 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.