0

I'm struggling to add /usr/local/bin to my PATH so I can use geckodriver, which is located in /usr/local/bin/geckodriver. I tried the to add the following to my config.fish

set -U fish_user_paths /usr/local/bin

and also

set -gx PATH $PATH /usr/local/bin

both approaches don't seem to work. When I try to use geckodriver after restarting fish I get the error

Command 'geckodriver' is available in '/usr/local/bin/geckodriver'
geckodriver: command not found

which is weird because it seems to find it but can't execute it. Any solutions?

Thanks in advance

  • after you updated your config.fish, did you source it again? – glenn jackman May 1 at 17:39
  • First, I recommend not using fish_user_path. It tends to cause more problems than it solves. Stick with the set -gx PATH solution. Second, the Command 'geckodriver' is available is not from fish. It's presumably coming from the geckodriver command because you are missing some other prereq of that command. You can confirm that fish is finding the right program by typing type geckodriver. – Kurtis Rader May 1 at 18:35
  • Somehow after extracting geckodriver again and putting it in /usr/local/bin it works now. Your comment on missing some prereq pointed me to the solution though. So thanks! – kachink May 3 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.