12

On bootup, I get an OpenVPN dialog that says:

"OpenVPNServiceInteractive" is not started. Tasks requiring administrative access may not work.

OpenVPNServiceInteractive not started dialog

If I disregard the message and try to connect to my VPN anyway, I will get another error later on when OpenVPN tries to setup the routing table.

If I quit open VPN, wait a while (a few minutes), and then try again, I no longer get the error dialog.

1 Answer 1

11

The problem is that the OpenVPNInteractiveService is set to startup Automatic (Delayed). To resolve this:

  1. Open Services
  2. Open 'OpenVPN Interactive Service'
  3. Change the Startup type: to Automatic.

Services List

The service incorrectly set to delayed automatic start:

Delayed Start

The service corrected to automatic (non-delayed) start:

Automatic Start

More Information

OpenVPN developers said to make sure the service is set to Automatic:

Also, as installed, the service start type is auto, make sure it has not been changed to delayed-auto.

OpenVPNInteractiveService is:

... a Windows system service which allows unprivileged openvpn.exe process to do certain privileged operations, such as adding routes.

From Windows Internals, 6th Edition page 327:

After handling auto-start services, the SCM calls ScInitDelayStart, which queues a delayed work item associated with a worker thread responsible for processing all the services that ScAutoStartServices skipped because they were marked delayed auto-start. This worker thread will execute after the delay. The default delay is 120 seconds, but can be overridden by the [sic] creating an AutoStartDelay value in HKLM\SYSTEM\CurrentControlSet\Control.

3
  • 2
    I had this error and I can confirm that this fix helped.
    – Mateng
    Commented Sep 20, 2019 at 12:31
  • Also, don't forget to actually start the service, if it is not running currently.
    – mike
    Commented May 5, 2020 at 10:22
  • I have this problem in Windows 7. But OpenVPN Interactive Service is already set to Startup Type=Automatic. Nevertheless I still got that error anyway... "OpenVPNServiceInteractive is Not started". But by the time I check in Windows Services its status is "started". I guess it's not starting quickly enough? Commented Nov 12, 2020 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .