1

I should start by describing my computer setup. I have 2 desktop computers (call them D1 and D2) running Windows 7 and a laptop (call it L1) running Windows 10. D1 and D2 are connected by CAT5e to an unmanaged Netgear GS105 5-port gigabit switch. This switch is then plugged directly into the modem. I also have a Linksys Max-Stream AC4000 wireless router plugged into the modem, and that broadcasts to L1. L1 is my main computer and I generally use the desktops for computation-heavy tasks.

Several days ago, I had 1Gbps fiber installed to my house. This was an upgrade from 12Mbps DSL that I'd had for 15 years. The modem went from an old 2Wire a/b/g to a BGW210-700 n/ac. Before the technician left, I had used speedtest.net and speakeasy to confirm the upgrade on D1 and D2. They both read ~910mbps download and ~600mpbs upload. Good stuff.

For the last few days, I've exclusively been using L1, and everything I've been downloading has been running at 80mbps (max wireless speed on 2.4Ghz), so it's been good. However, I tried to download some large files (500MB to 1GB) on both D1 AND D2 today, and for some reason they both only downloaded at 12mbps- the old internet speed. It's almost as if they are in the habit of downloading at 12mbps and are continuing to do so. That doesn't make any sense, right? Meanwhile, L1 is continuing to download at 80mbps, and the local connection between D1 and D2 is operating as fast as the slowest hard drive (500mbps).

Here's what I've tried:

  1. Unplug and replug the power to the unmanaged switch
  2. Plug D1 and D2 directly into modem
  3. Restart the computers
  4. Disable/Re-enable the ethernet in device manager
  5. Update Firefox/Chrome (the firefox update actually downloaded at 90mbps sustained somehow on D2)

Nothing works- everything downloads on both computers at 12mbps using Firefox, Chrome and CURL. Google speed test also shows 12mbps. Both speakeasy and speedtest.net still show proper 900mbps. I don't use a hardware firewall, I don't use a VPN, I don't have any network throttling software installed, and both desktops have 10/100/1000 onboard ethernet. I've tried downloading a 1GB file from a website (requires username/password) and also some test files from https://www.thinkbroadband.com/download. I did this on D1, D2, and L1 using Firefox, Chrome, and CURL. L1 is 80mbps across the board, and D1 and D2 are both 12mbps or less. The only thing that has gone above 12mbps on the desktops was the Firefox update on D2, which I don't understand.

What is going on and how do I fix this?

  • 2
    what happens if you plug in the laptop to the ethernet of one of the desktops and disable wireless? – Keltari May 4 '19 at 4:17
0

I ended up using a utility called TCP Optimizer from https://www.speedguide.net/downloads.php. All I did was set the bandwidth to 100+ and click the optimize option. On restart, everything was working as it should- full speed. Still not sure exactly which setting change caused it to work, but it does now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.