0

Recently I bought two more RAM sticks with same specs and brands as the two 8GB RAM sticks I have installed. However, the computer won’t start after I install two new RAM sticks. The screen is dark, mouse with LED doesn’t light up, indicator on keyboard doesn’t light up as well.

My System is:

  • CPU: Ryzen 1600x
  • Motherboard: Asus Prime B350-plus
  • Memory: HyperX Fury 2400 4x8GB

Also I found it doesn’t work when I install RAM sticks on slots with different colors. No matter you install two or three or four RAM sticks, as long as there are two RAM sticks in slots with different colors, it won't boot up.

What could be the issue? I've already reset my BIOS to default settings. And I believe my BIOS is the lastet version. Even if it's not, it should also support 4 DIMM RAM sticks which is the case in motherboard's handbook.

I checked timings of all 4 modules. They are identical. See pictures below.

Old Modules New Modules

SPD of Old 1 SPD of Old 2

SPD of New 1 SPD of New 2

As I said, all modules should be identical because they are same brand, same model. Also I don't think the problem is from slots. I tried old ones on both A1B1 and A2B2 and they both worked. Same thing for new modules. So it should not be slot issue.

It only doesn't work when you have modules in slots with different colors, whether there are 2 (A1A2) or 3 (A1A2B1 or A1A2B2 or A1B1B2) or 4 (A1A2B1B2) modules installed.

3
  • 2
    To start with, test each single RAM stick in all of the 4 slots one by one and repeat the same for all other 3 sticks to check if RAMs / Slots are working or not. Sometimes unused slots may accumulate some dust preventing perfect contact with RAM pins. Clean all slots with IPA Cleaner or some sort of air blower or if not available then using a soft brush but very gently. Then test 2 RAMs in slots A2 B2 then A1 B1 and then all 4 in A1 B1 A2 B2 and check again. Also swap the pair between 2 channels as well and check again.
    – patkim
    May 4 '19 at 4:54
  • 2
    (Continued...) Check if the exact model number is listed as QVL for this board on Asus motherboard website. If you are using Windows OS also do check out the memory specs by running free apps like CPU-Z. If there's a way or a provision in BIOS to under-clock the RAM speed from stock 2400 to 2100 give it a try too.
    – patkim
    May 4 '19 at 5:01
0

Its all about the memory timings, and using the lowest common denominator.

CPU-Z Here the memory tab indicates the active timings.

CPUZ spd Here are the timings at different frequencies.

So first you need to find the best clock speed all chips are capable of, and the look at the SPD tab.

Mark down all of the timings of each chip. For each setting pick the highest value among the 4 chips.

Then go into the BIOS and manually set the values accordingly.

Also the voltage has to be correct.

0

Check your power supply.

I had the same problem you described where the computer would not boot with 4 DIMMs. It started with BIOS errors saying the RAM had changed, as 2 DIMMs would no longer register. The OS also became corrupted and would not boot.

Auto Repair went around in circles and would not boot cleanly into the OS. I swapped out all 4 DIMMs and the problem continued, suggesting either MOB or PSU, but not MEMORY.

I replaced the PSU (Low end SHAW PSU with a better ANTEC PSU. Same MEMORY and MOB, no problems. I also monitored the old PSU using the MSI Control Centre utility and all three voltages that were tracked were jittery. The ANTEC voltages look much more stable.

So check your PSU.

0
0

Here's my post on Tom's Hardware, but I'll paste it here, in case the website delete's it or shutsdown. https://forums.tomshardware.com/threads/new-ram-computer-wont-post.411519/

TLDR: disconnect the power plug from the PSU. Disconnect the 24 pin power connector and 4+4 pin CPU power connector from the mother board; disconnecting CMOS isn't necessary but probably wiser to do so. It seems the problem is the 'residual voltage' or whatever it's formally called.

So for the past 7 years, I've been running G.Skill low cas latency ripjaws with the Red colored plate, 2x2gb + 2x4gb for a total of 12GB DDR3 ram. Eventually upgraded from an AMD Phenom II to a 4th generation Intel i5 in 2018. I bought the blue colored G.Skill rip jaws 2x8GB ram, in hopes of running 24GB total. The Asus Z87 plus (link) is a very high end motherboard that comes with a power button, BIOS flashback, and a DRAM check button (link) on it.

Went ahead and got a replacement motherboard on a eBay for way more money than it would have cost 2 years ago, but of course it came with expedited shipping. The Gigabyte motherboard was DOA, so I figured I'd plug the Asus back in since I remember reading a forum post about reseating the HSF to get it to boot.

Okay computer booted with 1 stick of ram. So common sense told me, I needed to get rid of the ground, I.e. make sure mobo is not connected and not touching the metallic computer case. Since I'm lazy I only disconnected PSU power pins and power cable, and thankfully that's all that was needed.

I was able to get the computer running with 24GB, but there were bizarre inconsistent results. Sometimes I would have to turn off then turn on the monitor. The USB keyboard wouldn't emit a green light. I would restart the PC and then it wouldn't post.

So it made sense to stick with just 2x8GB and accept only getting a 25% increase in RAM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.