2

My Nvidia graphics card is Geforce 940M along with Intel HD Graphics 5500 card.The output of this command is

lspci | grep -E "VGA|3D"

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)<br>
0a:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)

I am using Ubuntu 18.04.02 LTS. The output of

lspci -v


0a:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)
Subsystem: Hewlett-Packard Company GM108M [GeForce 940M]
Flags: bus master, fast devsel, latency 0, IRQ 255
Memory at c4000000 (32-bit, non-prefetchable) [size=16M]
Memory at b0000000 (64-bit, prefetchable) [size=256M]
Memory at c0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 3000 [disabled] [size=128]
Expansion ROM at <ignored> [disabled]
Capabilities: <access denied>
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

I am not able to install nvidia driver on system through GUI

enter image description here

1

At some point you installed a Nvidia driver manually, probably using a binary file downloaded from Nvidia (not recommended) and that's the reason why it now shows "Continue using a manually installed driver" and not allowing other options (install a tested version from the repositories).

Start by purging the Nvidia drivers already installed:

sudo apt purge nvidia*

Reboot.

This should now allow selection and installation of drivers at Additional Drivers. The 390 version shown is adequate for your GeForce 940M but if you want to install a newer version like 418 which is also compatible with the hardware or 430 (beta) you need to add an additional software source, the graphics drivers PPA:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update

Now the newer drivers versions should show up in Additional Drivers. Select, apply and reboot as usual.

  • I rebooted after executing "sudo apt purge nvidia*. but softwares and update gui still does not allow to change the graphics options. – Asis May 4 at 17:59
  • Please do sudo apt install nvidia-390 and report back the error, if any. – GabrielaGarcia May 4 at 18:03
  • I install nvidia-390, now i can select any driver out of 7 by gui. I selected 390 and reboot. but nvidia-smi shows output as: 'NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.' – Asis May 4 at 18:22
  • In Details about section shows graphics i using is Intel® HD Graphics 5500 (Broadwell GT2) . – Asis May 4 at 18:29
  • That's a serious mess. Likely the result of what you tried to install before you noticed the issue in question (but not mentioned though). The purging should have corrected it anyway but may not if you tried to install a binary of a version newer than 390. If you already added the PPA try to change to the same version previously installed by a binary with the Additional Drivers. – GabrielaGarcia May 4 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.