12

Last month, probably in Firefox 66, a new feature showed up - picture in picture video. Now when I exit a YouTube tab playing a video and go somewhere else on the website, the previous video hangs in the lower right corner of the screen, and if I hadn't paused the video, it plays.

This is obnoxious and I'd like to disable the feature. I've looked online, but the flag from about:config that was used to enable PIP in beta, media.videocontrols.picture-in-picture.enabled doesn't seem to exist anymore.

Are there any ways to disable it? Given the fact it's now a WebAPI draft, more websites could implement it, so solutions that aren't YT specific are preferable.

| improve this question | | | | |
  • Hmm. "As of this writing, you need to install the latest build of Firefox Nightly in order to try the feature in action. " and "Please keep in mind that Picture-in-Picture mode in Firefox is a work-in-progress as of now. It may not work reliably and doesn't have many customizable settings or features." from Firefox is Getting Picture-in-Picture Mode – DavidPostill May 5 '19 at 16:31
  • "it's now a standard WebAPI" No it isn't. It's still a draft. – DavidPostill May 5 '19 at 16:41
  • I am not using Firefox Nightly. I am using Firefox 66.0.3 from Ubuntu 16.04 repositories – Syfer Polski May 5 '19 at 16:42
  • 3
    Indeed. What you are seeing is not Firefox's PIP but Youtube's PIP. Other sites such as dailymail.co.uk/home/index.html also have a similar annoyance where scrolling the page causes an embedded vid to go PIP. It is not Firefox causing it. – DavidPostill May 5 '19 at 16:46
  • Mine is also broken, where the blue icon sticks around on some videos and does not go away. I have the media.videocontrols.picture-in-picture.enabled flag in Firefox Developer 69.0b1, but turning it off does nothing. – rovyko Jul 4 '19 at 20:50
6

To hide the button just right click it and click hide. You won't see it anymore.

| improve this answer | | | | |
1

I see the same thing. In about:config, setting media.videocontrols.picture-in-picture.enabled to false doesn't do much, but setting media.videocontrols.picture-in-picture.video-toggle.enabled to false as well seems to do the job. Tested in Firefox 71 beta.

| improve this answer | | | | |
  • Doesn't work in Firefox 70 Stable, but I'll wait for the update and hope you're right – Syfer Polski Oct 30 '19 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.