1

I travel and use VPNs a lot and one very annoying consequence of this is that Google, among other sites systematically redirects all my searches to the local version, which usually ends up being in a language I can't understand, and also different page ratings from the English ones.

It's trivial to solve this by signing in to my Google account (where the language is set to English) or by using another search engine (Chrome in particular). But on Safari the solution has eluded me, because changing the default search engine on Safari only allows you a restricted set of choices of which the default English Google (Google NCR) is not one.

There is a Safari extension called Omnikey which, in theory, allows ne to solve this problem: you can add any number of custom search engines and it will then make this the Safari default. But it requires you to configure a search URL. I have tried https://www.google.com/ncr, https://www.google.com/search?q=%s, but with no luck.

Any suggestions as to what the correct way of doing this might be?

1 Answer 1

1

Google chrome settings Add search engine: Search Engine: Google NCR Keyword: ncr

In the URL field https://www.google.com/search?q=%s&pws=0&gl=us&gws_rd=cr

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 3, 2021 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.