1

I'm attempting to install Ubuntu 16.04 alongside Windows 10 on a Dell G315, but keep getting the error of not having enough space on my drive, despite allocating 161GBs for Ubuntu.

I've created a Ubuntu 16.04 USB using Rufus & the ubuntu 64 bit LTS image. On my Windows side, I then shrunk my C: partition using disk manager; I have 7 partitions (boot, C:, 161GBs of unallocated, winretools, image, dellsupport, and 16 MB of unallocated)

Based on advice online, in Windows, I went to control panel -> all control panel items -> power options -> choose what the power buttons do and disabled "turn on fast startup"

I then booted into the BIOS settings by pressing F12 as I was starting up, and disabled secure boot; I left secure boot mode in deployed. I checked that I wasn't in legacy startup mode, and then under boot options added a new option for my ubuntu usb.

I then hit apply changes and exit, and rebooted the computer into the ubuntu on the usb, but about halfway through the install I get a message that I only have 7.8 GB on my computer and ubuntu needs 8 and a bit. I booted into the linux trial, and ran gparted, only to see the 7.8G of the USB.

I would think that this is likely a problem with secure boot not allowing me to see the full harddrive, but I'm certain it's at least disabled on the BIOS and don't know where else it might be enabled.

Thanks for any help you may have.

  • 1
    It's unrelated to secure boot. It has to do with the SATA mode: It needs to be AHCI, not RAID, Intel SRT, ... Please note you may need to install AHCI drivers in Windows before changing to that mode or it may not boor. – user931000 May 6 '19 at 20:16
1

I had the same problem with installing Ubuntu 16.04 alongside Windows 10 on a G3 15. I solved it by first going into the BIOS and changing to AHCI mode instead of RAID on. Then rebooted and installed Ubuntu into the premade partition made with Windows.

I then had the problem that I couldn't boot to Windows anymore so I followed this guide and it solved that problem. For the TLDR;

  1. Switch back to RAID and boot to windows and change to boot with Safe Boot Minimal
  2. Reboot to enable your BIOS AHCI option
  3. Safe Boot into Windows and disable Safe Boot
  4. Boot to Windows 10 normally and check in device manager that AHCI is enabled

Finally, I had an issue of trying to log into Ubuntu 16.04 and it freezing on start up and shutdown (in recovery mode). So I booted into recovery mode through grub, and did ...

sudo -H gedit /etc/default/grub/

and changed...

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

and then ran

sudo update-grub

I then rebooted and I could log-in normally. I hope this works for anyone out there too. If it doesn't work on the same make with Dual-Boot windows feel free to slate me if there's any steps I might have missed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.