4

I have a virtual machine on VirtualBox (version 6.0.6), guest system CentOS 7, host system Windows 10. Extension pack is installed. Graphics controller is VBoxVGA.

I followed the steps here for installation of VirtualBox Guest Additions (no errors displayed) and reboot.

On CentOS:

> systemctl -t service | grep vbox
VBoxadd-service.service   loaded active running VBoxadd-service.service

(that means guest additions are running). "Auto resize guest display" is still greyed out.

About current kernel:

> sudo uname -r
3.10.0-957.12.2.e17.x86_64

Note that on the same host, Fedora 30 virtual machine and Ubuntu 14.04 virtual machine "auto resize" properly works.

Update: still happens with VirtualBox 6.0.8 (updated Extension Pack and Guest Additions too).

Any hint? What I'm missing?

1

I had a similar issue (didn't read all of your references though, short on time) and for me it worked with 3D acceleration enabled and grafics controller VBoxSVGA. Noting else changed.

I am on version 6.0.12 on the host and the additions are 6.0.14.

| improve this answer | |
0

My solution was to set the display to VBoxVGA (VirtualBox 6.1.6 r137129 Qt5.9.5, Guest additions installed, Debian 10)

| improve this answer | |
  • 1
    ... instead of the suggested VMSVGA – Rodrigo May 5 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.