I cannot seem to get Unity to recognize my Android phone when I try to build and run.

I have JDK 8.0 installed. I have the Android SDK installed, with platforms 7.0, 7.1, and 8.0. My device is Android 7.0.

I have Google USB drivers installed.

I have USB debugging enabled on my phone. I have the proper path to the SDK in Unity. I have tried restarting Unity and my phone.

I can't figure out whats wrong. I even killed ADB in task manager.


I just had this problem as well. All settings were in line with what I had been reading on posts. I fixed it by entering the developers tools on my phone and going directly to the "Select USB Configuration" tab and setting it to PTP (picture transfer protocol). Seems strange but for some reason chrome could then see my device and Unity build and run worked perfectly. Hope it helps.


To all Huawei owners check that under network is actived USB tethering,then activate USB debugging. I was changing SDK,downloading all sorts of ADB and USB drivers. Breaking my head 2 days until i find in some webpage that Huawei requires that USB tethering is on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.