1

I am using Dell Inspiron 7560, dual booted with Windows 10 and Ubuntu. Windows is installed on a 128 GB SSD and Ubuntu is installed on a partition of a 1TB HDD. Each of the drives also have an EFI partition at their beginning for the respective operating systems. After a recent Windows update, which possibly has installed some patches for Boot Manager, the bootmgr variable has been set to the EFI of the HDD, rather than to the EFI of SSD, as it was earlier.

Before the Update, the options were:

  1. Windows Boot Manager
  2. Ubuntu

Now my UEFI boot has these options:

  1. Windows Boot Manager ( wrongfully set to EFI of HDD)
  2. UEFI: SK Hynix 128GB Partition 1 (SSD, Windows EFI bootmgr)

The Ubuntu (GRUB) option has somehow vanished. The first boot option fails to boot Windows (rather brings up Dell Recovery), but the second one is working fine and boots into Windows. I tried to change the device for bootmgr through BCDEdit on Windows, but it fails and the bootmgr goes back to the same wrong EFI partition.

Here are some additional facts that may help in diagnosis:

  1. From a Ubuntu live installation, I saw that there were no Windows boot files on the HDD(Ubuntu) EFI and the Windows boot files on the Windows EFI partition also seemed to be intact.
  2. After a recent repair, I had reinstalled Windows 10, which went into the HDD(default) and had then to be cloned to the SSD. I then installed Ubuntu on the HDD.
  3. This is one of the first Windows update being done on my laptop, after being reset at the beginning of March 2019.

I suspect that Windows identifies the EFI partition of the lowest numbered Disk (Disk0=HDD) to be the Windows EFI partition during UPDATES. This possibly leads to creation of a new boot manager entry pointing to the Ubuntu EFI and a imaginary Path: EFI\Microsoft\boot\bootmgfw.efi with name "Windows Boot Manager", while the existing one is sidelined to be given the default name SK Hynix Partition 1.

  • 1
    You only need one EFI partition. And which one is used can be set by changing the drives order in UEFI settings. – user931000 May 8 '19 at 16:34
1

I found the solution. The problem was that the windows update had added a new boot entry from the HDD (containing Ubuntu). This happened possibly because Windows Update expects boot to be in the first disk (Disk0), whereas this disk contained Ubuntu. This new entry with name Windows Boot Manager simply fails as there is no Windows bootmgfw.efi at the directory to which it points to. It is likely that ubuntu boot entry was also deleted in this process.

The solution is: in the BIOS at boot time, I had to add another boot entry for Ubuntu. I chose the correct file (efi/ubuntu/shimx64.efi).

There are a lot of answers that suggest to modify boot entries in BIOS. A lot of them mention accessing EFI NVRam, which I could not understand. NVRam is non-volatile RAM. EFI NVRam hosts the boot options.

It must be noted that this might not be a permanent solution. A yet another Windows Update may bring back the same trouble. But this time around we know the remedy.

  • 1
    +1 for trying. There are two way to dual boot. Grub can chainload Windows EFI or Windows EFI can chainload Grub. Also EFI partition should be in one drive. – Biswapriyo May 19 '19 at 12:21
  • Due to a recent incident when one disk failed, I chose to create separate EFI partitions, so that in the case of disk failure, I have at least one OS working. – shreyase99 May 19 '19 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.