0

I'm trying to set up my local Wordpress instance for development. I've changed the permalinks to http://localhost/localwp/%postname%/ and my .htaccess file was updated successfully: screenshot of the permalinks screen

.htaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /localwp/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /localwp/index.php [L]
</IfModule>

# END WordPress

Well, this just don't works. I've been searching and found issues about mod_rewrite being disabled, so I made sure mine one was properly enabled on /etc/sysconfig/apache2 (weird path, but its the default at the distro I'm using). Also phpinfo() confirms that the mod is enabled.

Even with mod_rewrite enabled I keep getting 404 when I try to access any post, even using the "View" button on WordPress. e.g: http://localhost/localwp/pagina-exemplo/ (pagina-exemplo is portuguese for example-page, and its created automatically by Wordpress).

If it matters, there is some more details I extracted from phpinfo:

Apache API Version  20120211
Loaded Modules  core mod_so http_core prefork mod_unixd mod_systemd mod_actions mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_host mod_authz_groupfile mod_authz_core mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_expires mod_include mod_log_config mod_mime mod_negotiation mod_setenvif mod_ssl mod_socache_shmcb mod_userdir mod_reqtimeout mod_version mod_php7 mod_rewrite

My distro is OpenSuse Tumbleweed 20190428

0

I fixed by adding

<Directory /srv/www/htdocs/localwp>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

to my /etc/apache2/httpd.conf file. Where /srv/www/htdocs/localwp is where is located my Wordpress files

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.