Every time I run certain applications (including but not limited to GIMP, Microsoft Visual Studio, and 3DS Max), I get the following message box:

There is a problem with your tablet driver. Please reboot your system. If the problem persists reinstall or update the driver.

Obviously I've tried rebooting and that hasn't fixed anything. Secondly, I'm not running a tablet PC. This is just Windows XP SP3 running on a Dell Precision PWS490 desktop workstation.

How do I get rid of these error messages? The applications still load normally after dismissing them, but they're rather annoying.

Using Process Explorer, I got the call stack from the message box. It's coming from wintab32.dll. Here's the call stack when running GIMP (irrelevant frames omitted):

8   USER32.dll!MessageBoxA+0x45
9   wintab32.dll!WTMgrPacketHookExA+0x44a
10  libgdk-win32-2.0-0.dll!gdk_display_list_devices+0x37

So, does anyone know how I can get an updated version of wintab32.dll or have any other ideas? I've been keeping my system up to date with Windows Updates. The timestamp on wintab32.dll is 2007-03-30 17:38, and its MD5 sum is ffdc332007c9dc6dd346c8ac2b09a015.


I've tried uninstalling a bunch of Wacom HID drivers as per BloodPhilia's suggestion and rebooting, but sadly this problem is still occurring. One driver, Virtual Keyboard Driver, will not let me uninstall it (the "Device usage" combo box is disabled), and another one, Virtual Keyboard Interface, reappeared after rebooting even though I'd uninstalled it:

Device Manager screenshot

Driver Details for the the VKD points to C:\WINDOWS\system32\DRIVERS\WacomVKHid.sys, and for the VKI yields the error "No driver files are required or have been loaded for this device.". Attempting "Update Driver" for both of them yields no results.

Any idea on how to uninstall this Virtual Keyboard Driver?


There was some software installed named "Tablet" in C:\Program Files\Tablet. Removing it via the Add/Remove Programs dialog finally made these error messages go away:

Add/Remove Programs dialog screenshot

Uninstalling this also deleted C:\WINDOWS\system32\Wintab32.dll (though for some reason there's also a Wintab32.dll in C:\i386, but I don't think that's being used since it's not in my %Path%).


This is caused by a (previously) installed HID (Human Interface Device). This could be a mouse, a keyboard, but most likely a drawing tablet such as this one:

alt text

When a such a driver fails to install (correctly), the "There is a problem with your tablet driver. Please reboot your system. If the problem persists reinstall or update the driver." will show up when opening a program that loads tablet drivers. (Such as graphic design programs as Photoshop, GIMP, etc.)

To correct this problem, the driver needs to be uninstalled. Click right on My Computer -> Manage, Computer Management pops up -> Device Manager.

Check for irregularities/errors in:

  • Human Interface Devices (Most likely)
  • Mice and other pointing devices (Second most likely)
  • Keyboards

Uninstall the (currupted) tablet driver.


Try booting into safe mode and remove the drivers again, before rebooting, rename C:\WINDOWS\system32\DRIVERS\WacomVKHid.sys to WacomVKHid.sys.backup. Then try and reboot.

  • Oh interesting, that's probably it. Our artists have a couple of those tablets lying around the office, and it's quite possible one of them used this machine at some point in the distant past. Removing the suspect drivers there doesn't seem to have fixed the problem for now, but I haven't tried rebooting yet after that. – Adam Rosenfield May 20 '10 at 20:40
  • Please let me know if it's solved! (And if it's not solved of course!) – BloodPhilia May 20 '10 at 20:48
  • Thanks for the help, but it's sadly not solved (see update). – Adam Rosenfield May 20 '10 at 21:48
  • See my update for more instructions – BloodPhilia May 20 '10 at 22:00
  • Still no luck =(. I rebooted into safe mode and uninstalled the Virtual Keyboard Interface (VKD still wouldn't let me uninstall it) and renamed WacomVKHid.sys (as well as a few others: wacommousefilter.sys, wacompen.sys, and wacomvhid.sys) as you suggested and rebooted. The Device Manager displayed a yellow warning icon next to the VKD and then let me uninstall it, but I'm still getting the error message after doing that and rebooting again. Any other ideas? Thanks for the help so far. – Adam Rosenfield May 21 '10 at 1:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.