To put it bluntly, mplayer is unable to correctly play video DVDs. It seems to correctly find the title and everything, but the picture is broken or not displayed at all, with messages like:

a52: CRC check failed!
a52: error at resampling                                           
[mpeg1video @ 0xa8d840]sequence header damaged                     
[mpeg1video @ 0xa8d840]Missing picture start code

Now, this all is on amd64 Gentoo Linux system. I believe the problem is not in mplayer itself, since the playback also breaks in VLC or when i copy the VOBs via vobcopy and try to play them afterwards.

I use libdvdcss-1.2.10 and libdvdread-4.1.3_p1168 (current stable in Gentoo), and tried previous versions of both libs, but it didn't change a thing.

The DVDs I have tried play fine in regular DVD player or on a Windows laptop. I remember the playback used to work about a year ago and I don't know what to try next. Any hints would be welcome.

  • 1
    Imho the DVD is borked, you should just try to rip it on the Windows laptop. – Apache May 20 '10 at 20:53

I've got it! It's caused by multithread decoding I have enabled. For some reason it b0rks MPEG-2 decoding. If I remove the setting (or use -lavdopts threads=1) everything is fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.