1

I am using DavMail in order to use Thunderbird 60.6.1 (32-bit) on Windows 10 (1809) to interface with a non-mailserver; that is my company's instance of Exchange.

Now what's odd about this is that I have to save my credentials for three different purposes directly related to DavMail.

  • localhost:1025 is used for SMTP (sending mail)
  • localhost:1080 is used for CalDAV (calendar)
  • localhost:1389 for LDAP (address book and so on)

DavMail settings dialog

IMAP is fortunately available to access the mailbox without the help of DavMail.

Now Thunderbird manages to save all of the above and I can see them saved in the password manager (Tools -> Options -> Security -> Passwords tab -> Saved Passwords).

Thunderbird saved passwords dialog

The screenshot already nicely illustrates the issue by way of the Last Changed column. I am being prompted for the password of localhost:1080 all the time, whereas all the others persist and work fine (i.e. the services also work as expected).

Now, initially I thought the reason for this behavior was that I am using Scheduled Tasks to start both DavMail and Thunderbird. Both are individual tasks triggered by a logon of my user account with a 10 second delay for DavMail and a 60 second delay for Thunderbird. In theory that should take care of certain dependencies not being up, although localhost should really always be available - and early on.

However, I can rule out that scenario, because even if I close both DavMail and Thunderbird, then start DavMail, followed by a check that the services it provides run on the given ports (only with netstat, though), and then starting up Thunderbird again gives me the exact same prompt and only ever for localhost:1080.

Password prompt for localhost:1080

Is there a way to ...

  1. find out why Thunderbird "forgets" the credentials for that particular service all the time ...
  2. make Thunderbird remember the credentials (both, username and password) persistently across program restarts.

NB: another observation I made is that when I enter the password at the prompt and forget to set the checkbox as shown, the next time around Thunderbird will prompt not just for the password but will also have forgotten the username (which is given in ad-domain\username notation).

2

I found a solution to this problem, which I also had on Ubuntu 19.04.

  • Thunderbird 60.8.0 (64-bit)
  • Lightning 6.2.8

What I did:

  1. deactivate the affected CalDav calendar in the list of (using properties/ uncheck "Switch this calendar on")
  2. terminate davmail
  3. remove the password authentication entry in the preferences/preferences/security/saved passwords menu
  4. close Thunderbird
  5. restart davmail
  6. restart Thunderbird
  7. switch on the troubling calendar
  8. re-authenticate, although: this time I used my email first.last@com.pa.ny instead of domain\userName.

and voila - it works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.