1

I recently updated PHP on my Laravel server (v 5.3.29) to version 7.2.15. In the process, I broke the project I'm working on. I've been looking at this for a few days but can't figure out why it broke.

My dependencies listed in composer.json:

    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=5.6.4",
        "laravel/framework": "5.3.*",
        "workerman/phpsocket.io": "^1.0",
        "firebase/php-jwt": "^4.0"
    },
    "require-dev": {
        "symfony/css-selector": "3.1.*",
        "symfony/dom-crawler": "3.1.*",
        "barryvdh/laravel-ide-helper": "^2.2"
    },

Error I'm getting in my logs:

Illuminate\Foundation\Bootstrap\HandleExceptions->handleError(2,
'count(): Parame...', '/var/www/[directory]k...', 1231, Array)```

Any idea why this could be happening? Any help would be appreciated.

1

It seems that you do not meet the Server Requirements. You've got "laravel/framework": "5.3.*" (Laravel 5.3) installed. Laravel 5.3 requires "PHP between 5.6.4 & 7.1.*" as stated in the documentation. Thus, PHP 7.2.15 does not meet this requirement.

You must have at least Laravel 5.4, because as I can see from the documentation it requires PHP >= 5.6.4.

The best solution would be to update your Laravel to version 5.5 as it requires PHP >= 7.0.0 or even the most recent one. I highly recommend that you apply some kind of version control (for example, git) or at least backup your programming code before making this update. (if you haven't done so already)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.