3

The image should explain the problem quite well: Access denied services.msc

This system of me is in german but I guess you should understand the problem. I try to set "start type" to automatic for aswbiDSAgent which is my current Anti-Virus program (Avast Anti-Virus). I always have to start it manually which obviously makes it quite useless.

When I try to do this I get an access denied message (I started services.msc as an administrator). What can I do about that?

1
  • Did you set the service to manual in the past? First, I would suggest you repair your Avast install to make sure it's working OK. If it doesn't report a problem, this may be an optional portion of the Avast product, or Avast may only start this service when it is required. – music2myear May 10 '19 at 21:24
2

Firs, as @music2myear states, reinstall (if need be, first uninstall) Avast! to fix the issue.

Second, there are Registry keys for each Windows Service that determine Start type and other attributes. These are under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\ and can be used to set the start type. However, to protect these Services, ownership may have been set to TrustedInstaller, so even an Administrator cannot alter the data. To do so, you need to take ownership of the key.

N.B. This can cause unexpected problems later, such as preventing updates, so set ownership back after making changes. Also, the ownership may be changed during software or Windows updates.

1

I tried to change my AVG Antivirus service like OP and I received the same error message. At first, I thought of changing registry values in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\*]. As expected, I didn't have the necessary privileges to change the "Start" dword value which corresponds to the "Startup type" options.

Registry editing

I couldn't assign necessary permissions (Full Control) to my user, so I tried a tool called SetACL, which has helped me a lot of times in situations like this. This time however, I wasn't able to do anything. Instead, SetACL reported back to me:

Operating system error message: Access is denied.

It's the first time I encountered something like this. I was hoping to be of more help, but I decided to write down what I tried in case it ever helps anyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.