0

This ServerFault answer avouches that 'print' ought appear:

enter image description here

but why doesn't it for me? Please see below.

enter image description here

1

I expect you figured this out by now, but for future right-click-print-haters: you need to uncheck "Options -> Hide Standard Menu Items" which is checked by default.

The Windows default "Print" that appears below "Open" for many file types, and results in thousands of pages of paper being wasted daily, will then appear in the list. Type CTRL+Q to show the "Quick Filter" control, filter on "print", and then you can disable it.

enter image description here

1

I think you are looking in the wrong place, at the wrong entries.

The screenshot in the answer you linked dates from some time ago and probably from another version of Windows.

The Print entries can be found under other names, such as &Print and 3D Print (the new nifty print option in Windows 10).

Here are some examples from my computer:

enter image description here

  • Thanks! Problem solved. +1. I hope others, like me. to upvote your answer that helps as much as that which I accepted. I accepted another answer not by reason of any difference in helpfulness, but because SE allows only one acceptance that I have bestowed to those with less reputation. – Greek - Area 51 Proposal Jul 17 at 0:06
1
+50

CTRL + F to find entries. Type "print". Press enter. I see that Print's actually "&Print" on the list. Note: "&" here means hotkey (underlined letter), so &Print becomes Print in the context menu and Pre&view becomes Preview.

Alphabetic sorting puts things beginning with "&" at the top, together with the other &'s (&Edit, etc.) That's why you didn't find it between preview and repair. It's between &Play and &Register instead, a lot higher up on the list. Here is a ShellMenuView picture: ShellMenuView

Addendum: When modifying your shell via registry, sometimes changes are only applied on the next login. So log out and back in (or reboot your whole machine, whichever is more convenient for you) and check again. It might have worked!

Advanced: Hate logging out? Me too! Open Task manager (Ctrl+Shift+Esc) and terminate explorer.exe (Windows Explorer) and then launch it again via: File → Run new task. It will reload your shell — with the new registry changes applied — without logging you out or closing your running applications.

(Edit: Rewrote my whole answer, misunderstood question.)

0

Just remove the registry with reg delete command in Command Prompt. Let .txt file as an example.

  • Get the file extension association: assoc .txt
  • Delete the registry as administrator: reg delete HKCR\txtfile\shell\print /F
  • Sometimes there is also another registry: reg delete HKCR\txtfile\shell\printto /F

Backup the registry if needed. The deleted registry can be easily imported from .reg file. The command can also be used in a for loop for multiple file associations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.