1

I have ESXi based home lab and creating new private network with DD-WRT router. I am not infrastructure expert but virtualization is easy nowadays and really helps a lot except issues like this.

Home Router > ESXi Public Network switch | ESXi Private Network Switch > DD-WRT router (VM Appliance) > Computer [no internet?]

DD-WRT router is a appliance from VMWare, set to use static IP from home router.

192.168.0.21 (dd-wrt)
255.255.255.0
192.168.0.1 (home router)
rest 0's

Now, computer on this router is not able to ping www.google.ca but shows IP address and works from router's command shell.

ping from computer

ping from router's command shell

I had DD-WRT build which is lost and use to work without any issue and pfSense also work but would like to use new DD-WRT as pfSense seems to be bit more techy. I would like to use DD-WRT to able to remote machine using RDP and not sure how to set it up using pfSense.

Either this 2019 version of appliance is buggy or not sure what's wrong,

Any help will be really appreciated...

  • What is the reason for the ddwrt virtual router? It seems unnecessary. – JohnnyVegas May 11 at 20:09
  • I am working on it, next week there will be windows ad, exchange and other development solutions... – MDU May 12 at 0:01
  • n without internet it will hard to manage them, pfsense will work instead of dd-wrt but don't want to use because it be techy and can't setup static routes easily like dd-wrt to rdp machine from my machines on home network. – MDU May 12 at 0:12
  • To start troubleshooting the setup, Can you ssh into the ddwrt and see if you can ping google from there? – JohnnyVegas May 12 at 12:21
  • Erm... Static routes are extremely easy to setup in pfsense... 😑 Read the getting started docs – Tim_Stewart May 16 at 18:45
-1

Disable firewall in DD-WRT and see if that works, if it doesnt then check PfSense firewall logs, you might have forgotten to add a "Allow" rule to pass the traffic to WAN.

Also you havent specified if you are using WAN or LAN port on your DD-WRT router.

If you are using WAN, disable DHCP, disable WAN, and set a static IP for DD-WRT router in basic settings, and plug the cable into one of the LAN-s

I am running traffic from PfSense to another AP router without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.