9

Every time I launch a specific program, User Account Control pops up and asks me the following:

Do you want to allow this app to make changes to your device?

This question arises even when I run as admin.

Can I somehow add a publisher to an approved list, so I don't have to answer this question every time I launch a program from this publisher?

1
  • 1
    Which type of program? Win32 or UWP? Did you mean UAC notification or other? A screenshot will be helpful.
    – Biswapriyo
    Commented May 12, 2019 at 3:46

3 Answers 3

3

You can use UAC Trust Shortcut for this. Basically it creates a shortcut to the app you want to run that is somehow exempted from UAC. Kind of hacky, but it works.

1
  • That's exactly what I was after. Thank you!
    – J M N
    Commented Feb 26, 2020 at 0:33
4

Go to:

Control Panel\ User Accounts and Family Safety\ User Accounts

Click “Change User Account Control Settings”

You should now see a vertical slider that governs what UAC does. At the top should be “Always Notify,” and at the bottom should be “Never Notify.” Slide it all the way to the bottom if that the setting you desire, then reboot. Windows should never trouble you again.

(Information from here)

N.B. This setting will apply to all apps, not just a single one.

4
  • 11
    Thanks Bill. Does anyone know of a solution that works on an app-by-app basis, rather than compromising my computer's security?
    – J M N
    Commented Jan 17, 2020 at 0:10
  • 1
    I also came here looking for a "per app" solution.
    – Homer
    Commented Jan 18, 2020 at 17:03
  • This answer works perfectly for me. I have been running a "fake sudo" from Cygwin command line: cygstart --action runas [COMMAND]. This answer will prevent that annoying popup and make my life much easier. /// It will also be useful from Windows, where many of the libraries with which I develop are in R&D phase or open-source, so I have to give permission, even when running as Admin. Commented May 26, 2020 at 15:54
  • Archived version of the source ... you know, because pages can disappear. Commented May 26, 2020 at 16:07
0

Found a method that worked in my case as all of the methods described here and on other forums didn't work properly

  1. Open control panel
  2. Open Administrative Tools
  3. Double click Local Security Policy
  4. In the new window, in the left panel expand the Local Policies tab
  5. Expand Security Options
  6. Below the right panel you will see: User Account Control: Behavior of the elevation prompt... (note there are 2 versions chose the longer one)
  7. Double click and set the value to: Elevate without prompting

https://www.czetsuyatech.com/2011/01/diable-do-you-want-to-allow-following.html

1
  • 1
    This does not just approve specific publishers or programs. Did you even read the question? Commented May 26, 2021 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .