1

My network setup has two routers. The WAN on Router 1 is plugged into the internet. Router 1 has about a dozen computers, including a bunch of home routers plugged into it. I just setup a Network Printer on Router 1, and configured a computer on Router 1 to print to it. The printer is on TCP/IP and is confirmed working.

One of those home routers is mine. My Home Router (Router 2) has several computers attached. I would like to print to the printer on Router 1. Router 2 is a TPLink Archer 9. I can't figure out whether I'm using Virtual Servers or Advanced Routing or something else. At the very least I suppose I could disable the DHCP on Router 2 and turn it into an access point, but I'd rather not do that yet.

Is there an easy way to do this?

  • 1
    If Router 2 Has a different subnet, There isn't going to be an easy solution to this, or any at all as far as I know. – Sickest May 12 '19 at 23:20
  • Can I ask you why you're using this many routers? and not using them as switches? You also might want to tell us which printer you're using. – Sickest May 12 '19 at 23:23
  • 2
    You can use the printer on network 1 by simply installing it by IP address. Make sure the printer has a static IP so it doesn’t change. Install the printer software or manually install the printer port and driver by using the IP address of the printer. I’m not aware of any printer installation software that doesn’t have an option to manually specify an IP address for the printer. – Appleoddity May 13 '19 at 3:15
2

Case 1:#

There is no Firewall policy (on Router 1 or Router 2) which forbids communication between "Subnet 1"(Printer network) and "Subnet 2"(Your PC network), you should be able to utilize that printer without hassle, though, you have to install that printer manually and target it by IP address or its DNS/NetBIOS name.

Some help on the Manual printer install, extracted from this article:

  1. Open "Settings".
  2. Click on "Devices".
  3. Click on "Printers & scanners".
  4. Click the "Add a printer or scanner" button and Wait a few moments.
  5. Click The "printer that I want isn't listed" option.
  6. Select the "Add a printer using TCP/IP address or hostname" option.
  7. Click the "Next" button.
  8. Use the "Device type" drop-down menu and select the "TCP/IP Device" option.
  9. In the "Hostname or IP address" field, type the IP address of the printer. For example, 10.1.2.175.
  10. In the "Port name" field, leave the default name (recommended) or type a new name.
  11. Check the: "Query the printer and automatically select the driver to use" option (recommended) Make sure you have a correct driver for your printer!.
  12. Click the "Next" button.
  13. Type a name for the printer and click "Next"
  14. Select the: "Do not share this printer option" and Click the "Next" button
  15. Finish your printer installation.

Case 2:

You have some Firewall rules, which prohibit communication between "Subnet 1"(Printer network) and "Subnet 2"(Your PC network), set in place... You need to tweak them:

  1. By utilizing Source NAT and/or Destination NAT
  2. Opening Your printer ports/protocols and allowing traffic to pass freely through them for Subnet 1"(Printer network) and "Subnet 2"(Your PC network)
  3. Clear/Tweak the Firewall rules completely and let those two networks talk to each other without any restrictions.

After you have tweaked your Firewall rules, and allowed those networks (your PC and that Printer) to talk to each other, go back to Case 1 and install that printer manually.

| improve this answer | |
  • 1
    Well, "No firewall" policy is the usual case for LAN→WAN traffic. – user1686 May 13 '19 at 4:37
  • 1
    @fixer1234 Thanks. I have edited my response, hope it's somewhat better now. I'm not quite a good with explanations I always assume that people have a similar thought process as I do. But I'm willing to improve :) And to answer your question: Based on the info He provided I believe that there is a good chance that He don't have any FW rules in place(in regards to those two networks, maybe a NAT for his WAN on "Router 1". – Leshy May 13 '19 at 11:28
  • @grawity His question heading is a little bit vague. Read his question again. I have given him the solution for what I have "seen" in his question. If I'm making a wrong assumption about his setup then He can speak up and I will act accordingly. I find this way easier. Although I should have posted my Answer as a comment first, it's my first time so... – Leshy May 13 '19 at 11:48
  • This was very helpful. Both routers use the 255.255.255.0 subnet. I forwarded the port using Virtual Servers, but now the concern is if other computers on Router 2 are going to be able reach the printer. Port forwarding only lets me specify a single IP address. I need to test this with another computer and get back to you. – ecogeek May 14 '19 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.