1

I'm havin trouble printing my glossary and acronym directory with the glossaries package. It produces an empty page where I call \makeglossaries. I suspect biber, babel or my build directory might be interfering with it.

My main.tex looks something like this:

\documentclass{report}
\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc} 
\usepackage[english,ngerman]{babel}
\usepackage{biblatex}
\usepackage[xindy]{glossaries}

\setacronymstyle{long-short}
\shorthandoff{"}
\makeglossaries

\addbibresource{head/bibliography.bib}
\loadglsentries{head/glossary}

\begin{document}
    ...40 pages of actual content about \gls{acr:ipd} and 
    \gls{BIM} and even more \gls{acr:ipd}...
    \printglossaries
    \printbibliography
\end{document}

With glossary.tex in the directory head:

\newglossaryentry{BIM}{name={Building Information Modeling},description={3D and shit. \lipsum}}
\newacronym{acr:ipd}{IPD}{Integrated Project Delivery}

Packages that I'm pretty sure are irelevant are omitted for brevity.

I have configured TexStudio to run the following sequence:

pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex
makeglossaries.exe -d build main
biber.exe --input_directory build --output_directory build main
pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex
pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex

The problem appears to be that makeglossaries doesn't actually do anything. All it logs is

makeglossaries version 4.41 (2018-07-23)
Changed to 'build'

No files are changed when I run makeglossaries manually. I have manually added the Perl directory to ENV; it is reachable from my working directory. I have tried swiching to xindy and back according to the documentation, but to no avail. I have switched the order of biber and makeglossaries. I deleted the build directory after every attempt.

What is going wrong?

Update: I have confirmed that makeglossaries does in fact do nothing. Running the MWE in a separate directory yielded the desired results and much more verbose console output from makeglossaries.

4
  • Did you try your MWE? Do you see the same problem with it? Did you check what happens if you run makeglossaries with -n? Do you have makeindex and/or xindy available?
    – Seth
    May 13, 2019 at 12:38
  • Yes, I did try the MWE in another directory. To my suprise, it works without issue (I guess it's not a proper MWE then). -n has no effect. Whether I use Xindy or not has no effect.
    – azrael
    May 13, 2019 at 13:30
  • You could try to build that MWE within the same directory to see whenever the directory is the problem. If it is not you know that one of the other packages seems to be interfering.
    – Seth
    May 14, 2019 at 5:12
  • After copying the entire directory to another location and renaming the main file to something other than main without effect I have ruled out the path as source of the issue. It's probably some other package but I didn't have the patience to figure out which one.
    – azrael
    May 14, 2019 at 8:20

1 Answer 1

1

Turns out the makeglossaries script is the issue. It just didn't do anything. No idea why. Luckily, it isn't supposed to do much more than call Xindy or Makeindex. I solved the issue by bypassing it with a file called build.bat:

pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex
xindy  -L german -C din5007-utf8 -I xindy -M "build\main" -t "build\main.glg" -o "build\main.gls" "build\main.glo"
biber.exe --input_directory build --output_directory build main
pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex
pdflatex.exe -src -synctex=1 -interaction=nonstopmode -aux-directory=build main.tex

Because I like working with TexStudio, I have set the second line as the makeglossaries command in the configuration and continuing with my regular build sequence.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.