0

I went to this GitHub page to install seasnake.

I tried pip install seasnake but got this error:

ERROR: Could not find a version that satisfies the requirement seasnake (from versions: none) ERROR: No matching distribution found for seasnake.

I have been looking for answers for two hours now on the web, but nothing helped me.

  • You don't mention your version of Python, but the PyPI page for seasnake indicates that only up to Python 3.5 is technically supported. – Anaksunaman May 13 at 17:59
  • I have the 3.7 version of Python. – magox May 13 at 21:21
  • which OS you are trying to install? – Biks May 15 at 6:35
  • @Biks Mojave 10.14.1 – magox 2 days ago
0

You are getting this error because file is not present in pypi. Hence you need to build from source code.

Steps to Install in Ubuntu

  1. Compile Sealang as mentioned in the git(https://github.com/pybee/sealang)
    • sudo apt-get install libclang-3.6 clang-3.6 -y
    • sudo apt-get install zlib1g-dev libncurses5-dev -y
    • export LLVM_HOME=/usr/lib/llvm-3.6
    • export LD_LIBRARY_PATH=$LLVM_HOME/lib
    • pip install sealang
  2. Compile Seasnake
    • sudo python ./setup.py install

Now you would be able to use Seasnake. Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.