macOS Mojave, version 10.14.5 and VirtualBox 6.0.6.

I'm trying to install VirtualBox on my iMac, my iMac is running the latest Mojave. I've searched for a solution to this and whilst there are plenty of results, none of them work for me. All of the post I've found show an option in the "Security & Privacy" dialog which I just don't have:

Mac Dialog for Security and Privacy

Mine doesn't have the Allow button or the text to the left of it. I've read it over and over and I'm pretty sure I've followed the instructions correctly, but I just don't have that option.

Is there a fix for this can I install VirtualBox?

[Edit] I tried running from the terminal, on my iMAC, the path:

  • /Volumes/Macintosh

doesn't exist, I do have:

  • /Volumes/VirtualBox
  • /Volumes/iMAC

When I tried:

sudo installer -pkg /Volumes/VirtualBox/VirtualBox.pkg -target /Volume/iMAC

I got:

installer: Package name is Oracle VM VirtualBox
installer: Upgrading at base path /
installer: The upgrade failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

[Edit #2]

This is what I did:

With "VirtualBox-6.0.6-130049-OSX.dmg" in ~/Downloads and using Finder I opened the DMG file.

VirtualBox Installer

I then Double click on the VirtualBox.pkg icon.

The following is displayed: Installing VirtualBox

I click the "Continue" button in the popup dialog, then "Continue" in the remaining dialog.

Standard Install on iMAC

I click on the "Install" button, then enter my password as superuser and click "Install Software" button.

After a very short time this is displayed:

Installation failure

I click the "Close" button and this is displayed:

Keep or move to trash

I click on the "Keep" button. Now having done this several times and failing I searched online and found instructions to do the following:

Click on the Apple icon (top left), select "System Preferences", from the window that pops up, select "Security & Privacy", the "General" is open by default. I click on the padlock and unlock. My image does not change to reflect what is displayed on the many other pages I found:

Security & Privacy

Thats it, I can't get any further...

[Edit #3]

Despite the reported errors, I just checked the "LaunchPad" and "VirtualBox 6.0" has been installed. I launched it and added the virtual machine I want to use which:


My virtual machine:

VirtualBox Manager

When I try to start this I get:

Error message


Error message 2

Having searched for the message displayed in the last error dialog, I uninstalled VirtualBox and tried again, no difference, I then uninstalled and this time rebooted the system then installed again, as some posts stated that this would solve the issue with the permission being displayed in the "Security & Privacy" dialog, still I don't see this and still no further forward.

Any help gratefully received...

  • Can you try unattended installation via mounting the VirtualBox installer image, then running sudo installer -pkg /Volumes/VirtualBox/VirtualBox.pkg -target /Volumes/Macintosh\ HD from a Terminal?
    – slhck
    Commented May 13, 2019 at 19:30
  • @slhck, thank you, please see my edit...
    – SPlatten
    Commented May 13, 2019 at 19:52
  • 1
    Hm. I think it would be good to describe the actual steps you are performing when doing the GUI-based install (i.e. double-clicking the .pkg file, then clicking through installer). What happens and where exactly are you getting stuck?
    – slhck
    Commented May 13, 2019 at 20:03
  • I'll edit my post and add the full instructions.
    – SPlatten
    Commented May 14, 2019 at 6:52
  • 2
    Just wanted to add that this is extremely comprehensive and reproduces exactly what I'm seeing. Thank you!
    – Gingi
    Commented May 17, 2019 at 18:44

4 Answers 4


The solution was posted:


Install Virtual box on mac OS +10.3 with security kernel can failed. After you have this message :

Kernel driver not installed (rc=-1908)

because you have to add editor Oracle in the list of security kext.

If you have chance, you can see the ask for authorisation in Preference -> "Security and Privacy".

But it was not my case. I want to share the solution, because it was a really pain for me: Add Oracle editor in this authorization list.

Restart your mac in Recovery mode (cmd + R)

Then open a Terminal and enter : spctl kext-consent add VB5E2TV963

Restart your mac.

VB5E2TV963 is the code for oracle.

  • There is an easier and shorter solution proposed by the user @theguy here Commented Oct 6, 2019 at 5:24
  • 1
    Doesn't work for me.
    – Max S.
    Commented Oct 30, 2019 at 9:13
  • 1
    Perfect solution, worked on Catalina 10.15.4 MacBook Pro (16-inch, 2019) Commented May 20, 2020 at 5:03
  • 2
    This worked for me as well, was only solution that would work! To boot into recovery mode do command+r then select terminal and enter in the command then type reboot and it will work!
    – RCG
    Commented Jul 23, 2020 at 0:01
  • Thank you, sir! Worked for me as well. Commented Apr 13, 2022 at 15:57

Apple states in tech note tn2459 that it only prompts once and that the text in the system preferences is only visible for 30 minutes.

I did the following to view the allow button again:

  • close the system preferences
  • install virtual box again (it states that it failed)
  • open system preferences - security: and the allow button appeared again
  • Virtual Box worked for me

In Terminal run:

sudo kextcache --clear-staging

For me it worked without a reboot, if it didn't work for you try with a reboot.

  • 1
    This worked for me. I had no issues installing but was crashing on trying create a VM or starting it after. Running this command, using the uninstall tool, restarting, and reinstalling worked for me. Needed file access and keyboard access to get it to work (which it prompted me during the first creation of a vm) Commented Sep 29, 2021 at 16:22

First, you might try install via terminal:

~ brew install virtualbox

VirtualBox requires a kernel extension to work.
If the installation fails, retry after you enable it in:

System Preferences → Security & Privacy → General

For more information, refer to vendor documentation or this Apple Technical Note.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .