1

I am attempting to partition my HDD using parted in non-interactive mode. The below commands partition the drive as expected, then on completing install and configuration then booting I see an error saying I do not have an EFI partition setup.

parted /dev/sda mklabel gpt
parted /dev/sda mkpart primary fat32 1MiB 500MiB
parted /dev/sda mkpart primary linux-swap 500MiB 8.5GiB
parted /dev/sda mkpart primary ext4 8.5GiB 23.5GiB
parted /dev/sda mkpart primary ext4 23.5GiB 100%

I believe this is because the Fat32 boot partition is not flagged as boot. I am able to boot successfully when partitioning using interactive mode.

How can I set the boot flag on this partition without using interactive mode in parted?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.