0
  • Gigabyte Aorus X470 Gaming 7 WIFI
  • AMD Ryzen 2700X
  • Windows 10 Pro 64-bit v. 1903
  • BIOS F31
  • AMD Chipset driver v. 19

I have enabled SVM in the BIOS. I have installed Hyper-V in Windows components.

I'm running msinfo32 and expect to see four items related to Hyper-V. Instead, I see: "A hypervisor has been detected. Features required for Hyper-V will not be displayed."

How do I enable Hyper-V??

PS My goal is to run Docker natively, without VirtualBox. When I try to setup Kinematic, it says:

screenshot

  • answers.microsoft.com/en-us/insider/forum/… – user931000 May 14 '19 at 8:43
  • @GabrielaGarcia Thx, but it looks irrelevant. None of the registry entries they suggested to delete existed in the first place. And I don't have a "secure boot" option in my BIOS. – lolmaus - Andrey Mikhaylov May 14 '19 at 9:34
  • If you see A hypervisor has been detected. Features required for Hyper-V will not be displayed." then Hyper-V is enabled. – essjae May 14 '19 at 16:50
1

Starting Hyper-V Manager and setting up a virtual machine has proved that Hyper-V is working correctly.

After that, Docker started working! Not sure if it's a coincidence.

UPD: Docker wasn't working for me because legacy VirtualBox-driven Docker had been installed and overwritten env vars. Hyper-V-driven Docker was mislead by those env vars and failed to start properly.

Deleting legacy Docker and removing its env vars by hand resolved the issue for me.

|improve this answer|||||
0

If you have message showing like this image saying

"A hypervisor has been detected. Features required for Hyper-V will not be displayed."

simply means that you have already running Hyper-V currently.

You no need to go for other configurations.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.